Email delivery does not work

Hello,
I have created a mailbox and had all DNS entries set, yet I only ever get “Address does not exist” as a response from mailservers. As an Example here is a response from Exchange:

<[email protected]***.***>: host amir.mx.cloudflare.net[172.65.14.34] said: 550 5.1.1
    Address does not exist. *** (in reply to RCPT TO command)

All DNS entries were automatically created by Cloudflare and DNS caching etc should not be a problem anymore, the entries exist since yesterday. My ticket at Cloudflare was unfortunately closed without response.

Greets, Sören

Could you try toggling catch-all off, then on again? :slightly_smiling_face:

catch-all was off, but toggling to both options didn’t helped :frowning:

There’s been some cases where the routing configuration didn’t propagate to the mail servers automatically. Toggling catch-all will force push the configuration, so that’s why I suggested trying that.

Can you confirm you’ve set up a rule for [email protected] and that the destination address has been verified?

This is my setup:


I just noticed that I forgot to copy an information from the ticket: I’m using an IDN, I know that this is always a bit problematic with emails

Unfortunately, IDNs aren’t supported at the moment :confused:
https://developers.cloudflare.com/email-routing/known-limitations#internationalized-domain-names-idns

That’s a shame, but it’s better to know what the problem is than to be left in the dark. Thanks for the link!
Then I will wait until IDN is supported :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.