Email client is not working after using Cloudflare

My email client stopped working after using Cloudflare.(Timeout)

I referred to the Cloudflare article https://support.cloudflare.com/hc/en-us/articles/200168876-Email-undeliverable-when-using-Cloudflare and set up the DNS, but it didn’t work.

I also check the article in the community https://community.cloudflare.com/t/email-not-working-since-switching-on-cloudflare/41068/9

and the final DNS and email client set up is like this:


Neither the service name with or without mail worked.

The SMTP port for Secure SSL/TLS Settings in Cpanel is 465.

I have tried everything I could try but still no luck.

Thanks in advance for any help.

One issue is your first MX record. It points to your apex domain (not the ‘mail’ subdomain). You should delete that, as they’re both the same anyway.

As for the email client, you need to make sure it’s configured to connect to your ‘mail’ subdomain and not the main domain.

2 Likes

Thank you for your help.

Now the setup is like this.

It is still not working. Maybe I need to wait for a while?

Looks good to me now.
Yes, maybe some time due to DNS change.

Are you trying to connect to your e-mail server via secure (using an SSL connection) or unsecure connection?

1 Like

Thank you. I will report here once it works.

I am now using secure connection (SSL/TLS).

It is working now. Thank everyone.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.