Email client can't receive or send emails


#1

I am using Bluehost for my web hosting: domain.com as well I have email: [email protected] on same hosting.
Website works well, but I can’t get my email to work.
Webmail on cpanel for the hosting works fine, but email client on windows (Mailbird) does not.
I can connect to the email with Mailbird, but I can’t receive or send any emails.

For mail I have added:
A mail IP_Adress (Gray icon)
MX @ mail.domain.com priority-0
MX @ domain.com priority 10

Did contact Bluehost multiple times, but they were not able to solve the issue and asked to contact Cloudflare support, so here I am.
Any ideas why this is happening?


#2

Cloudflare doesn’t proxy non-http traffic.

So you should be pointing your mail client to a host which is not orange clouded by Cloudflare (e.g. mail.domain.com should not be orange clouded).

What happens when you try to send or receive mail?


#3

So pretty much I can’t use the same hosting for web and email.
Nothing happens, it just shows that it is sending, but never does.


#4

Well you can use the same hosting for web and email, they should just at a minimum use different host names or in the mail client you can specify the actual IP address of the hosts instead of the host names because Cloudflare won’t proxy non-http traffic.

But for the Mx record… it really should point to a non-orange cloud record. We try to do some trickery to prevent customers from shooting themselves in the foot if they orange cloud an Mx, but it’s better to not point a gun anywhere near your foot than to rely on us making sure you don’t hit the target. :slight_smile:


#5

Mail uses mail.domain.com and A name for it is gray or non-orange cloud record.
Could the issue be that web and email use the same ip address?

Error from email client:
Server authentication failed.
Wrong settings or IMAP disabled on server.

p.s. English is not my native language.


#6

Should not be an issue that they use the same IP address as each is resolved separately.

I just attempted to connect to your mail.example.com record using telnet similar to the following (but with the real values) where 25 is the port used for SMTP, 143 is the port for IMAP and 993 is the port for secure IMAP. I was able to connect using both the name and IP address.

telnet mail.example.com 25
telnet 10.10.10.10 25

telnet mail.example.com 143
telnet 10.10.10.10 143

telnet mail.example.com 993
telnet 10.10.10.10 993

Those settings seem to match what bluehost suggests are the correct ones: https://my.bluehost.com/cgi/help/mac-mail


#7

Just tested and it worked on mac.
Will try again later on different email client for windows!
Thanks!


#8

I also use bluehost.
I can send emails using the domain hosted only on bluehost and not using cloud flare but the 4 sub-domains on the same account, I cannot send emails. I can receive. And I can send via webmail. I am complete non-techy and do not really understand dns settings etc.
My web developer assured me all was as it should be on cloud flare and blue host support cannot help.
I am using all settings they suggest.
websites are:


http://twitchynoses.org
http://theneuternetwork.org

I am at my wits end with it now as has been 2 weeks or more. For some reason theskibug emails did send for a while, and then stopped 2 days ago. I have not changed or done anything.


#9

I have the same issue - I do not really understand all the tech side but cannot send emails on accounts using cloud flare


#10

Same answers apply. Your Mx record is the same name as your website. We only proxy http (web traffic) and so email clients can’t connect using port 25 (SMTP) to that same host name.

As a result, to make sure customers can continue to receive mail we create a fake Mx record for you, but ideally you’d have your own MX record pointing to a gray clouded host such as mail.example.com. So you’d need both an A record (gray clouded) for mail.example.com and to change the existing Mx record to be be mail.

Or you could use the IP address instead of the host name for your mail client settings for the SMTP server and communicate with it directly.


#11

Ok, thanks.
But doesn’t work even if using other port, not 25.
So what should the mx record be?


#12

2 posts were merged into an existing topic: Email didnt working