Email Bouncback After Initiating CDN


New here and need some assistance. I seem to be having email bouncback from one of my contacts (only this one) after initiating CDN. As of now, I have the free plan, soon to upgrade to Business. I’ve been working with my server technicians and they cannot seem to help any longer as all server setting are good. This issue seemed to have come into play once I enabled CDN. BTW, I have Email disengaged as it I cannot seem to connect my email server through Outlook. I cannot send and recieve emails unless I use my webmail.

Any suggestions?

Thank you

See if this helps:

1 Like

I have the MX record, but it has my domain and I cannot edit it to add @ in place of the domain. I was able to add a record, but deleted too quickly when I noticed the MX record with the domain. I’ve tried to recreate it, but I receive a pop indicating “record already exists”

If the record exists and deleted, how can I retrieve it back?

@ is shorthand for the domain name. I think you have it correct.

What’s the domain?

Oh, ok. My domain is:

I see the MX record points to a mail server that responds to SMTP, POP, and IMAP. That’s good. Just make sure your mail client is trying to connect to that mail subdomain.

You’re saying that someone who sends you mail gets it bounced back? What does the error say?

Regarding my Outlook email client I use, are the setting that need to reflect CDN?

When I send out an email to multiple recipients, there is one that always seems to bounce back. The is the content of the email from Mail Delivery System (Note, for privacy, I modified some texts):

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

[email protected]


SMTP error from remote mail server after MAIL FROM:<[email protected]>:

451 4.1.8 Possibly forged hostname for XXX.XXX.XXX.XXX:

retry timeout exceeded

Thanks sdayman

Outlook should still be using (your domain) to send and receive email.

That error looks like anti-spam measures are kicking in. I see you have an SPF record. You should exclude the +a since your A records now point to Cloudflare.

And you have DKIM, which is good. With both of those in place, a DMARC record would be good for completing the setup.

I’m stumped as to why just that one mail host is rejecting the message. CDN shouldn’t be the issue, as the relevant DNS records haven’t changed.

Give this mail test a try:

1 Like

Regarding the spf record, in which record are you referring to. I see two that have v=spf1 in the values, in the TXT DOMAIN and TXT sewsletter. So I remove that from those values?

Also, could the recipient have an aggressive spam control where my domain would need to be whitelisted?

Also, for general information for the public, only use a TXT record for the SPF value. As the DNS record of SPF, which would seem reasonable to use, has been depreciated.

I didn’t check SPF for the ‘newsletter’ subdomain. But it shouldn’t have the +a either, as that subdomain is also behind Cloudflare.

I don’t think the recipient has so much control as to get the server to reject the message. Aggressive spam settings just dumps the message into their Spam folder.

That is what I thought, but I also understand there are means to reject unknown emails. But then again, we’ve been communicating for over a year now.

Anyhow, I did remove the +a from both values. I have a wait for 7 days to see how my email is scored from

Where do I setup DMARC?

Still working with my server techs to set up DNSSEC, should this help with my email issue?

I think mail-tester only makes you wait one day, unless they’ve changed something.

DMARC is another TXT record. Try this:

But here’s a quick one:
Change ‘reject’ to ‘quarantine’ for less aggressive handling. It will Spam it instead of bounce.

Thank you Sdayman,

Thanks for the direction to DMARC creator. That helped a lot. I’m hoping these changes will help with my issues.

Much appreciated sir!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.