Email (beta) routing not working

Hi all,

I am attempting to use the beta Email routing service on my domain (pack14oxford.org).

According to the Dashboard, my MX records are set up correctly for the routing service, my custom address is added and active, and my destination address is verified (see screenshot below).

I’ve attempted to email from both my work (Office365) account and a ProtonMail account, and in both cases I get the following error in a bounce:

<: host route1.mx.cloudflare.net[162.159.205.12] said: 521 5.3.0 Upstream error. zY5Aud4kKVqy (in reply to RCPT TO command)

I set up all of the DNS records and the mail route at least a week ago, so it definitely is not an issue of DNS propagation or anything like that…

Any thoughts?

I have the same problem, the same error “521 5.3.0 Upstream error. 2wfdZTao6H2M” on all domains, yesterday everything worked without a problem.

Hi @playaz44 @keschrich ,

I’m also using Cloudflare email routing but all is working good :+1: for me

Can you open a Support ticket and post the I’d here so that someone here will escalate it to the support team

I was unable to find where to actually create a ticket (are free users even able to?), but I did stumble upon the “Error messaging” tool and entered “521” as the error code. This led me to a similar community post ( Send email and get 521 upstream error ) 5.3.0 Upstream error. zY5Aud4kKVqy (in reply to RCPT TO command)which I hadn’t found earlier. The accepted answer on that post stated the problem is due to an infinite loop in the configuration.

While I’m not sure how this can be (I can send email directly to {redacted} with no issue at all), I changed the action “Send to” address to be the actual gmail account that the message would ultimately end up on, and I am now able to send without issue.

I’ve changed the target email to Gmail and I can also confirm that sending emails works. I’m on the free version and I can’t create a ticket. Changing the email to [email protected] results error 521 again.

1 Like

@keschrich Great to hear that your issue solved :relaxed:

Yes

2 Likes

#2430859

I do not know what more to post, no email other than Gmail works.

I am surprised that for the first day everything worked correctly, and after 24 hours it stopped.

I’m sure that someone here will escalate it to the support team, be test assured

I’m unfortunately unable to understand what you mean can you specify your issue a little bit so that any one in the community might help you !
Are you sure that you have added correct DNS records ?

I added all DNS records

If i’m set a destination email other than redacted receives error 521 5.3.0 Upstream error, only redacted works.

Oh I understand it now !

Please note that Cloudflare only offer service for forwarding

So if you send a message to [email protected] that sends to [email protected]

Yes, I know it’s forwarding but why doesn’t it work with other email addresses? Sorry for my bad English, I use a translator.

I already know why it does not work, if you set up on two different email forwarding domains and in the second you set the email from the first one and in the first domain email from second, then there is an error 521 5.3.0 Upstream error, setting another destination email, e.g. [email protected] email forwarding works.
The problem for me can be marked as solved, thank you for your help.

1 Like

Nice :+1:

Hi Nerraj,

While I was able to get around the issue, I’m not sure if I would consider it fully solved. The original destination address, while it does forward elsewhere, does not result in a loop.

I’ve created ticket 2431036 with description and screenshots. Thank you!

Hi @keschrich

Sorry to say but it’s Neeraj :sweat_smile:

There’s was a issue reported recently regaring email routing
https://community.cloudflare.com/t/cloudflare-configuration-changes-and-alerts-delayed/378228

Thanks for sharing it, Someone here will escalate it as soon as possible

Providing them here will help the people in the community to fix

@playaz44 there was a Issue with email routing recently that was reported can you check now & confirm is it working or not ? If not Please provide a Ticket No so that anyone here will escalate it to the support

1 Like

This post was flagged by the community and is temporarily hidden.

I’m having the same issues.

@gmail.com addresses work fine, but nothing else.

I’ve tried multiple other domain/mail providers (yahoo.com, InterMedia, my own mail server, - all get 521 5.3.0 Upstream error.

It was working but stopped at some point.

All DNS records are good.

Even tried deleting and re-adding things.

I’ve tried different domains in Cloudflare, same results. It is only working if you use a @gmail.com address as far as I can tell.