Email Adress not Getting into macOS Mail App


#1

Hello people!

Sorry to post something which have been asked so many times, but I’ve found no solutions yet.

I’m trying to get a webmail account into the macOS Mail application through IMAP or POP3, but it’s not working (it keeps appearing as in unsigned).

When talking with my hosting, they told me there could be a problem with the Cloudflare DNS. Hereby my configuration right now:

I already talked with my hosting, and they told me that the mail register on Cloudflare is correct, I’ve also put the cloud in grey mode, and tried deleting all the IMAP and POP3 registers altogether.

I don’t know what else to do right now.

Any advice?


#2

DNS looks correct. I can get to webmail there, but only with HTTP. If you want HTTPS, then you need to :orange: that entry.

Now for the catch. If it’s :orange:, then you can’t use your regular mail app for POP/IMAP/SMTP access.

Here’s what I would do:

  • Keep that mail entry as is, with the :grey:. You can use that for a standard mail app for POP/IMAP/SMTP, but you won’t be able to connect with SSL.
  • Create an entry for ‘webmail’ with the same IP address, and set it to :orange:. Use that for web access.

Later on, if possible, I’d explore the possibility of installing an SSL certificate on that IP address for fully secure connections, if possible. If that’s your server, then it’s possible. Right now, it looks like it has a default certificate for *srv.cat.


#3

It’s not really in my intentions to use any webmail service to read / send any mail, so I don’t think there’s a need to create a separate entry at all (thanks for the tip tho).

My only objective is to be able to act on the [email protected] email adress through the Mail macOS application, which is far more beautiful and pleasing, haha :slight_smile:

Right now, this is my problem:

Every time that I try to get the email account into the Mail app, be it through IMAP or POP3, this happens, and I can’t use the account.


#4

Where is that screen shot from? That doesn’t look like Mail.app to me.


#5

It does look odd, but if “unsigned” means it’s not making a successful SSL connection, you’ll have to use the actual server name in your POP/IMAP/SMTP configuration: vxmab-20.srv.cat


#6

The shot is from macOS System Preferences (Profiles) which is where the auto-sign executable from my Hosting sends me to.


#7

Thank you! This allowed me to open the account inside of the Mail app and receive mail – but I still can’t send any mails.

Any idea why this might be the case?


#8

For starters, turn SSL/TLS off for sending mail. At least see if it can make a successful connection that way.


#9

Still nope (sorry to unearth a zombie post, but was unable to work on this for some time).

Hereby some screenshots to demonstrate the current state of affairs.

The error:

The details:

The connection:

The status:


#10

I think in Server Settings you need to set that last option, Authentication, to “Password”.
Here’s why…

It looks like your IP (or your mail server’s IP) is blocked via spamhaus:
https://www.spamhaus.org/query/ip/95.42.16.244

https://www.spamhaus.org/pbl/query/PBL258586
“Important: If you are using any normal email software (such as Outlook, Entourage, Thunderbird, Apple Mail, etc.) and you are being blocked by this Spamhaus PBL listing when you try to send email, the reason is simply that you need to turn on “SMTP Authentication” in your email program settings. For help with SMTP Authentication or ways to quickly fix this problem click here”

FAQ:
https://www.spamhaus.org/faq/section/Spamhaus%20PBL


#11

Done, but no luck. Here’s the logs, if it helps.


#12

You also need to “Remove an IP from PBL” on this page: https://www.spamhaus.org/pbl/query/PBL258586
It might not be immediate.


#13

What IP should I remove? 95.42.0.0? Mine is different from that one (being 95.42.16.244).

Pd. Speaking with my hosting, I fixed the “connection” problems to the account using these specs, but still can’t send any e-mail.

They’re asking me to re-route smtp.anxl.faith to 46.16.61.250, and I’ve tried doing it like this (below) but I’m not sure I’m doing it correctly.


#14

The solution is entirely with your email provider. Its nothing to do with Cloudflare.