Either too many redirects or the site does not resolve at all


#1

I was able to get my https:// working on my site, but when I did a speed test I received this warning notice:

2 Redirect(s)

http://www.walterdemilly.com
301 redirect
https://www.walterdemilly.com/
https://www.walterdemilly.com/
301 redirect
https://walterdemilly.com/

So I tried going to the Crypto settings here and changing to FULL or FULL (Strict). These result in a 526 error.

If I change to Flexible I get this (in firefox)

https://walterdemilly.com/cgi-sys/defaultwebpage.cgi

In “e” I get a notice that this is an unsecure website.

And I’ve looked at the .htaccess file on my server. It is this and nothing more:

AddHandler application/x-httpd-php55 .php .php5 .php4 .php3

This is a wordpress site on a shared server. I would like to get the site working so that there are no unnecessary redirects, and the final URL is https://walterdemilly.com

Unfortunately, now, with all of the tweaking I’ve done I can’t get the site to resolve at all. When I speak to tech support for my server they say that the issue is not with them but with Cloudflare.

Any advice? Thanks.

(My account here shows that SSL is active).

PS I found another htaccess in the public_html folder. That file includes this:

#RewriteCond %{ENV:HTTPS} !on [NC]
#RewriteRule ^(.*)$ https://www.walterdemilly.com/$1 [R,L]

RewriteCond %{ENV:HTTPS} on [NC]
RewriteCond %{HTTP_HOST} ^walterdemilly\.com$ [NC]
RewriteRule ^(.*)$ https://www.walterdemilly.com/$1 [R,L]

Would that be the problem?


#2

You’ll always get at least one redirect if you don’t type in https for your Speedtest. And you’ll get a second redirect if you type in www as well. Cloudflare will redirect to https, and if you type in the opposite prefix, you’ll get that second redirect to www or non-www.

Your site is working now,

Right now, you have two resources using HTTP, causing that unsecure website warning: waltweb.jpg and bookshadow2.gif

You can try to use Cloudflare Crypto settings to turn on “Always Use HTTPS” and “Automatic HTTPS Rewrites.”

Another great method is to add this to your .htaccess file:
Header always set Content-Security-Policy: upgrade-insecure-requests


#3

Thanks, this helps I can fix the urls within wp for those images too.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.