Edge SSL certificate unable to activate and renewal issues

I have encountered my edge SSL certificate issues that cannot be activated and renewal, I have tried to buy your advanced certificate service but only Digicrt’s supplier is actived.

"Let’s Encrypt" will never register successfully, the certificate prompt “Initializing” if at advanced SSL registration, and the Universal SSL has always prompted “deleted”, what should I do? I have tried countless ways to delete the domain name, disable universal SSL then reactivate, except delete my account once.

Also I have already submitted the problem Ticket # 2316815, BUT THE STAFF REPLIED TO LAST 4 DAYS AGO, then he/she never didn’t reply to me again. Ticket status is still activated. May I know anyone can solve the my problem? Many thanks!

↓↓↓↓↓↓↓↓Even if I only keep “Let’s encrypt” certificate, the state is still “initializing” after one day.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.