Edge IP Restricted - Error 1034

before migrate to cloudflare, the website had a ssl certificated installed on the apache server. now we use cloudflare proxy to create a secure connection.

we use the universal ssl at cloudflare.

Hi,

I experience the same issue (error 1034). I changes the setup to point to 192.0.2.0 instead of 1.1.1.1. But, it doesn’t work… The error message no more appears and the domain name doesn’t reach the website. Is it any other element to configure, please?
Thanks in advance.

Greetings!

I am sorry to hear you are experiencing the same issue.

May I ask is the hostname proxied and set to :orange: ?

Did you purged the cache at Cloudflare dashboard → Cache → Configuration → Purge Everything upon the applied changes and waited for a few minutes?

1 Like

Thank you for feedback information.

May I ask is it still a valid one? Could you please check the expire date of it?

Okay.
May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

the old certificate is expired.
We use the full SSL connection.

It seems to work! Thanks a lot for your advices
Have a great day

1 Like

Thanks for feedback about it.

In this case, you would have to renew it.

Furthermore, if you used Let’s Encrypt or some other, before doing this, kindly enable the “Pause Cloudflare for this site” option from the Cloudflare Dashboard.
After renewing the SSL certificate at your server and testing out, make sure your Website works over HTTPS.
Upon success, un-pause and make sure your DNS records are proxied :orange: (as they were).
Do not forget to set the SSL/TLS option to the correct one → Full (Strict) SSL.

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to set up an SSL certificate using Cloudflare Origin CA Certificate:

Instructions as follows from below quote, just in case:

I replaced 1.1.1.1 with 104.21.3.243 and it seems to work.

It will work, until that IP is changed by another one automatically by Cloudflare as it often happens due to various variables. It’s a very bad idea…

2 Likes

Is there a other static IP available as a replacement?

Holen Sie sich Outlook für Android

No, you either use Cloudflare’s DNS as it’s supposed to be used, or you use the CNAME setup (which is available only to Business and up) or you don’t use it. That is an abuse which won’t work for long and it’s not guaranteed to be working for any amount of time.

5 Likes

You say “erroneously” but we were instructed to use 1.1.1.1 by Cloudflare Support so that we could setup a redirect from the naked domain to www using page rules. Is this really a breaking change? We have 1000’s of domains setup this way per your instruction.

1 Like

i met the same issue, follow @rommy tips i changed the records from A - 1.1.1.1 to AAAA - 100:: for workers routes, now the site returns ERR_CONNECTION_CLOSED, what can i do? thanks!

1 Like

to 192.0.2.1 or just using AAAA 100:: for Cloudflare Workers?
I use both A 192.0.2.1 and AAAA 100:: for naked domain and www (4 records in total) + using Page Rules to redirect non-www to www.

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?
→ Should be set to Full (Strict) SSL
After the change, are record proxied and set to :orange:?

now it works thanks, if i want to add wildcard (*) record, seems it can not be proxied?

Wildcards can only be proxied on the Enterprise plan.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.