Edge IP Restricted - Error 1034

All of a sudden we are getting an error 1034 that says our edge ip restricted. We only have the basic plan and no firewall. It provides me a Ray ID that I cannot search.

Any ideas?

2 Likes

May I ask does this happen on your own Website or when visiting/accessing someone else’s?

Furthermore, if it’s your’s website, are you using Cloudflare Pages, or some service/app or WebSockets?

Can you try to switch your hostname (DNS record) from :orange: to :grey: (DNS-only) if that helps to resolve the issue?

  • not knowing your configuration, but it could be CNAME domain.com or CNAME www

Also currently getting the same issue on two out of three of my domains, all three set up similarly. Very odd.

1 Like

also happening to my websites … example https://awake.vc

I’m also having this problem. it happened out of nowhere

1 Like

@bclaps @marcelo.matthew100 @user22222 @user20066 May I ask if you tried writing at ticket to Cloudflare Support?

Are all the DNS records set as they were or they changed?
Could you check your Cloudflare account → Audit logs for any clue, if possible?

May I ask if all of you are using the same hosting provider, maybe?

Can you share your domain names to Cloudflare Support?

Could any of the past incidents be realted to this?

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

I do get duplicated nameservers for your domain name when I check:
Nameservers:

cruz.ns.cloudflare.com
walt.ns.cloudflare.com
cruz.ns.cloudflare.com
walt.ns.cloudflare.com

We have opened a ticket the ticket id is #2355383. We are having the same problem and we are an enterprise customer. We are seeing this in our Azure environments.

2 Likes

@catfield Thank you for sharing some more details and a ticket number.

I’ve escalated this to Cloudflare technicians.

From what I can see, it appears that users that are using 1.1.1.1 in their DNS records or are resolving to that internally are impacted by this.
Can the users in this thread verify/confirm that they’re indeed using 1.1.1.1 in their DNS records or resolving to that internally?

1 Like

@arunesh90 We are using 1.1.1.1 to get out of our Azure AD Domain linked vms.

Yeah I also used 1.1.1.1 internally at my work for some of our domains, but seems like a change got pushed a couple hours ago to make this not possible anymore.
To be fair, this was a hacky workaround which I doubt was recommended by Cloudflare.

I can replicate this if when I switch from the IP from 192.0.2.1 (peoxied :orange:) to 1.1.1.1 (unproxied :grey: DNS-only) with a domain name with Cloudflare workers:

2 Likes

Hello. Do any of you have any DNS records pointing to 1.1.1.1?

I do have 1.1.1.1 - and it’s not working on https://awake.vc or iRealization.com

But it seems to work on https://awake.inc

I’ve tried to do everything.
I took my domain from cloudflare, changed ipv4 to another from cloudflare, changed some domain settings. Nothing resolved.

1 Like

We are having the same issue.

1 Like

If 1.1.1.1is the only A record you have, then you may get the 1034 error. Please test pointing your main A record to something other than a Cloudflare IP and see if the error persists.

Hello,

Customers who had erroneously pointed DNS records at 1.1.1.1 (or similar addresses) will receive an error 1034 (HTTP 403) going forward when attempting to send traffic via Cloudflare’s proxy.

We now validate that the hostnames landing on an IP address (or set of addresses) are associated with the same account in our systems, preventing misconfiguration and/or potential abuse.

Customers should ensure DNS records are pointed to addresses they control, and in the case a placeholder address is needed for “originless” setups, use the IPv6 reserved address 100:: or the IPv4 reserved address 192.0.2.0

10 Likes

Hi, i have the same issue. I put on my public ip into my DNS server, but now i have certificate issue. it seems that the cloudflare certificate doesn’t work anymore.

Sounds to me like you are having an insecure setup.
Before moving to Cloudflare, was your Website working over HTTPS connection? If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask is it related to the Universal SSL at Cloudflare, or rather you were paying for an SSL certificate to Cloudflare (using Dedicatel SSL / Advanced Certificate Manager) for your domain name?