Edge Certificates still Pending Validation for a week

Answer these questions to help the Community help you with Security questions.

What is the domain name?
vantrong(dot)com

Have you searched for an answer?
Yes, there is a same issue: 413424

Please share your search results url:

/searchresults#q=Edge%20Certificates%20pending%20validation%20txt&t=All&sort=relevancy

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?
This url is not accessable, it redirect me to /hc/en-us

Describe the issue you are having:
My domain was added to Cloudflare about 6 days or more. But I cannot access my domain, when checking the problem, I realize that Edge Certificates is still Pending. I’ve tried to disable Universal SSL for 10 minutes and turn it back on, twice, but still not working…
I created a support ticket yesterday, but I only receive an automatic response told me that current DNS record is DNS Only, but I’ve choose Proxied from the the moment that I add that domain. There is no other response until now…

I’ve checked DNSSEC and it enabled (tenten(dot)vn), I’ve added more than one hundred domains into my account, but this is the first time this step take too long…

What error message or number are you receiving?
Edge Certificates Pending Validation (TXT)

What steps have you taken to resolve the issue?

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

Have you tried from another browser and/or incognito mode?
Yes
Please attach a screenshot of the error:

Your domain’s DNSSEC is broken at your domain registrar - a registrar is the company that you pay for your domain registration.

To fix this:

  1. Follow our guide to Enable DNSSEC on Cloudflare to fix this.
  2. Test your domain again using letsdebug.net to ensure the fatal DNSSEC issues message is removed
  3. Visit the edge certificates dashboard and click Disable Universal SSL, wait 5 minutes and click Enable Universal SSL again - the certificate should become Active within around 15 minutes

Thankyou for your response. I will try these steps right now. :heart_eyes:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.