Edge certificate stuck at pending

What is the domain name?
getmagicpush.com

Have you searched for an answer?
Yes

Please share your search results url:

When you tested your domain, what were the results?
No change

Describe the issue you are having:
The edge certificate has been stuck on validating.

What error message or number are you receiving?
Pending validation (TXT)

What steps have you taken to resolve the issue?

  1. I tried adding the TXT dns records as shown in the popup when hovering the status, did not work.
  2. I did not setup any DNSSEC
  3. I have bunch of domains on cloudflare but the last 2 just did not work

Was the site working with SSL prior to adding it to Cloudflare?
On of my domains that is working is recently draw-ai-app.com. Did not have to do anything to verify the edge certificate. So is there a bug?

What are the steps to reproduce the error:

  1. Just add a domain

Have you tried from another browser and/or incognito mode?
Yes

Please attach a screenshot of the error:

You have a DNSSEC issue…
https://cf.sjr.org.uk/tools/check?df13fd0f6d1e4636842106cbde34d733#dns

You need to either disable DNSSEC at your registrar, or enable it at Cloudflare and copy the DS records to your registrar from your dashboard here…
https://dash.cloudflare.com/?to=/:account/:zone/dns/settings

1 Like

Done it! Thanks, now I will need to wait for the edge certificate to verify?

It may take some time for the DNSSEC change to propagate (up to 24 hours), then maybe an hour or so after that the certificate will be generated.

Okay thanks!! I will wait then

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.