Edge Certificate stuck at pending for weeks

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?
Yes, but unfortunately without success.

Please share your search results url:

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?

Describe the issue you are having:
Edge certificate does not want to generate a universal and backup certificate. DNS should be set correctly. NS points to your servers. SSL is set to Full strict. I read your forum multiple times, tried everything, even pressing the “Disable universal SSL” button and then re-enabling it. The status is stuck at Pending Validation (TXT) for several weeks. Can you tell me what i’m doing wrong? Thank you very much and have a great day.

What error message or number are you receiving?

What steps have you taken to resolve the issue?

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

Have you tried from another browser and/or incognito mode?

Please attach a screenshot of the error:

I figured it out during the time this post was being approved. The problem was in the DNSSEC configuration.

1 Like

Thanks for letting us know!