Edge Certificate Pending Validation more than 24h with .ch - Domain

Edge Certificate is in Status “Pending Validation” more than 24h. We tried everything for the last 5 days (including previous support ticket), and waited longer than 48h. Only one .ch-Domain is affected. Other Domains succeeded after a few minutes.

During the outage last week we first added this domain. After that we deleted and reset everything. But it seems, that entries are not erased after manual deletion.

Sorry by mistake sent :sweat_smile:

Thanks for your answers, but my problem is still not solved :pensive:

“Account Dash Ticket - Edge Certificate Pending Validation more than 24h” - @MoreHelp here would be really nice.

are you using Cloudflare Preumium ?

Greetings,

I am sorry for the pain and to hear you have an issue with the SSL certificate status.

Can you share your domain name here and post a full screenshot of your Edge Certificates page?

May I ask does that “Pending Validation” status stands next to the Universal SSL or Advanced SSL?

Have you tried temporary Disabling Universal and re-enabling it?

If you open up the Developer Tools (F12) on the SSL/TLS → Edge Certificate page, it should also show the actual error which would be very useful to know.

I’d suggest you to write a ticket to Cloudflare support due to your domain issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

Kindly and patiently wait for the reply.

May I suggest below article for help and troubleshooting:

Hey and thanks for your input!

saunaworlds.ch

Universal

I tried that many times. Also deleting and adding the complete domain doesn’t work out. The same with almost any combination of settings.

I already did. Ticket Number is: #2366266

1 Like

Hey ,

Did you successfully inputed the TXT Record

And was this your TXT Record
ca3-02b6603e947f4d0a858bc4243f51e169

1 Like

I use Cloudflare DNS-Servers and that should be done automatic (it was the same with my other domain names). I just tried to add this by hand and get the expected error:

A record with the same settings already exists. (Code: 81058)

1 Like

Thank you. I’ve escalated this.

Kindly and patiently wait for a reply.

3 Likes

You need to fix your DNSSEC configuration:

3 Likes

Bingo! Thanks a lot.

I just added the DNSSEC at my provider, with informations given by Cloudfront at DNS / DNSSEC. After disabling and enabling “Universal SSL” it works now like a charm.

By the way: A notice somewhere in the dashboard, why certificate validation does not succeed would help a lot for future cases.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.