Edge Certificate Pending for over a week

Hi everyone.

Can’t activate Edge Certificate, keeps showing Pending Validation (TXT) for over a week now. DNS Checker showing everything is ok but no luck in activating. I am using WordPress site and Really Simple SSL Plugin which is showing that everything is fine? Can anyone help me with this? Domain name: sinisazec.com

Assuming you have added the site to Cloudflare on a full setup, you haven’t set the 2 allocated Cloudflare nameservers at your registrar yet…
https://cf.sjr.org.uk/tools/check?61fa22fe4e704de2bdab6d7fffcd2511#whois

The 2 nameservers will be shown at the bottom of the DNS page here…
https://dash.cloudflare.com/?to=/:account/:zone/dns/records

You also have DNSSEC enabled at your registrar so you should disable that before changing the nameservers to avoid downtime. Once you are ready you can enable it at Cloudflare and copy the DS records to your registrar from your dashboard here…
https://dash.cloudflare.com/?to=/:account/:zone/dns/settings

I changed my nameservers earlier but that created additional issues. My records got messed up and DNS Checker showed errors on all entries. So I contacted my provider (Bluehost) and they told me I have to change nameservers back to default and they also said they will change DS records which they did. So now records are fine, but the SSL issue is still here. So what do I do now, do I change nameservers and try everything again from scratch? My knowledge is very limited so every advice is appreciated. Thank you for your time

Yes, I think others have found Bluehost seems to only be able to change DS records when the nameservers are set to their own.

At the moment, DNSSEC is still enabled there. You need to get that disabled before changing the nameservers to Cloudflare.

Make sure your SSL/TLS setting is set to “Full (Strict)” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls
…and that your DNS records are configured here…
https://dash.cloudflare.com/?to=/:account/:zone/dns/records

Once that is done, and DNSSEC is disabled, then you can change to the Cloudflare nameservers.

Ok, I’ll try that and see what happens. I’ll let you know of the results. Thank you

That was it, my SSL is up and running. Thank you for your help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.