Edge Certificate not Verifying

Hi there,

the Edge Certificate has had the status “Pending Validation” for over a day now. On the other domain in the same account, this worked instantly.
The Cloudflare DNS returned the right DNS records for it since the beginning.

It looks like this is not the first case: 2 Day Cloudflare edge certificates Pending Validation

Unfortunately, none of the topics have found a solution.

I just wanted to mention that Cloudflare API v4 Documentation returns success but on the UI the status doesn’t change.

Push.

Been down for two days. No reply on the support ticket either yet.

Greetings,

I am sorry for the pain and to hear you have an issue with the SSL certificate status.

May I ask if it’s for a domain name like yourdomain.com, or some sub-domain www.yourdomain.com / static.yourdomain.com, or maybe even for deeper sub-domain like www.sub.mydomain.com?
Can you share your domain name here and post a full screenshot of your Edge Certificates page?

May I ask does that “Pending Validation” status stands next to the Universal SSL or Advanced SSL?

Have you tried temporary Disabling Universal and re-enabling it?

Please, may I ask you to share your ticket number here so I could escalate it to Cloudflare engineering team?

May I suggest below article for help and troubleshooting:

What we have tried:

  1. Disable Universal SSL (on/off with many minutes in between)
  2. https://api.cloudflare.com/client/v4/zones/*/ssl/verification/
  3. Removed the domain from Cloudflare and added it back without importing DNS records

The issue persists. It is only this one domain. We never had this issue with any other domain before and added another domain at the same time.

The ticket id is: #2362491

I just noticed that the ticket was reduced from critical to normal (without comment/reply), although everything is offline during this time for us.

Also, Dev Tools on the cert page should also show you the actual error which would be very useful.

There is no error. It is just in the pending state forever.

The ticket says the issue is now solved. Putting this to solved.