Edge certificate is stuck on pending validation txt for more than 48 hours

Hi, I have the following domain sea-stat.com hosted at namecheap.com, My edge certificate is stuck on Pending validation txt for more than 48 hours, I’ve done the following:
-I’ve made sure to point the NS to Cloudflare NS
-My Cloudflare plan is Free
-I’ve added the correct DNS records.
-I’ve installed an origin Cloudflare certificate on my cPanel.
-I’ve made sure to try every SSL/TLS encryption mode from off to Full/Strict
-Tried manually adding the edge certificate _acme_challenge txt records, Didn’t work.

  • I’m getting SSL_ERROR_NO_CYPHER_OVERLAP error when trying to access the site from my browser.
    -Got frustrated then removed the domain from my Cloudflare account then re-added it, Still the same issue
    -Contacted NameCheap support, They said it I need to contact your support

I’ve done these changes and did a before and after test by activating and deactivating the Universal SSL, Pausing Cloudflare and then resuming it, Then waiting for 24 - 48 hours.
Nothing above worked

Your DNSSEC is invalid. Remove the records at your registrar.


1 Like

Thanks for looking into it
It worked like a charm, Thank you for saving the day
I was about to give up :raised_hands:

The issue was I needed to activate the DNSSEC in both my Cloudflare and Namecheap accounts even though namecheap DNSSEC settings was turned off

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.