Edge certificate is still pending_validation

Edge certificate is still pending_validation since last night. Have tried using this PATCH method to revalidate having setup -acme-challenge TXT records but still no change.

cert_pack_uuid is c1799051-bd17-4959-bda7-64093ac4cf8b

Please can support give it a poke to validate it. Many Thanks.

Confession: Just a note that the full 24 hours is not up yet.
However the site is currently without HTTPS until we can get this resolved so I am keen to get this working at the earliest opportunity

I discovered there is a DS record in the .com TLD. This is a DNSSEC related record. This is inhibiting Let’sEncrypt from generating an SSL on the host server. I suspect this same issue is inhibiting Cloudflare from validating the Universal SSL certificate.

When switching nameserbers a few months ago we did not follow the correct procedures as described here - dns - What is the recommend procedure for changing nameservers with DNSSEC enabled? - Webmasters Stack Exchange.

Hope that might help someone else with this issue.

I will post again if my updates at the domain register make the difference