Edge Certificate DELETED

Hello everyone,

I have a couple of domains where I accidentally disabled the Universal SSL option in SSL/TLS->Edge Certificate. Even after re-enabling, the status of the certificate is still deleted after 24 hours. The consequence of this is that I cannot use my domains with SSL.

I’ve found many topics in the CF Community similar to this one, and generally the fix is to disable/re-enable the Universal SSL waiting minutes/hours. I did it different times but nothing seems to be working.
I always used CF with many domains and no issues about SSL.
Probably this time I deleted too fast the DNS records while the certificate was pending for validation via TXT record.

Moreover, in the CF Community often this issue must be escalated to CF team which manually solve the issue. Unfortunately, it looks like impossible to me opening a ticket since when I click “get more help” the select domains below is grayed out.

Honestly I really don’t know what I can do at this point. I also emailed the CF team, but no replies from them since I understand they are very busy.
I only hope this post may gain attention on this issue in order to be solved.

Thank you.

Hi @ilcors,

Some people have managed to get a new certificate issued by changing CA using this API endpoint :slightly_smiling_face:

1 Like

You made my day.
Thank you very much!

I really hope this post may help other people in future :slight_smile:

1 Like

Hello, can you help me with the solution. I tried making PATCH request using POSTMAN and added all the headers to the requests. But, I’m not sure where to add ‘certificate_authority’ option in POSTMAN and my domain had Let’s Encrypt’s certificate. Do I need to change the value for certificate_authority?

The response I’m getting is,
{
“success”: false,
“errors”: [
{
“code”: 1401,
“message”: “Invalid request parameter(s)”
}
],
“messages”: ,
“result”: null
}

I would really appreciate if you help me.

I did it with CURL as in the suggested solution and it worked like a charm.
The only parameters you need are:

  1. your login email
  2. the api auth key
  3. the zone id for your website

Substitute these 3 values in CURL and you are right to go.

The result was always false, but somehow, the Universal SSL is active again. Thank you @ilcors, @albert for the solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.