ECH on Firefox does not work with WARP

If I enable WARP on my macOS and run the checks on https://www.cloudflare.com/ssl/encrypted-sni, “Secure SNI” is reported as disabled. If I disable WARP and instead use cloudflared DNS proxy, then ECH works. This issue was also reported in How my browsing is not private from ISP even with https?, but got closed without a satisfactory reply.

I have also played with Connection settings in Preferences; ECH does not work with any of protocols WARP, HTTPS, or TLS. As soon as I disable WARP and revert back to cloudflared, ECH is reported as enabled.