ECDSA instead of RSA causing problems on older browsers

Im having an issue with my Plesk.I have only one website hosted under my Dedicated Server using Plesk in Hetzner.Currently having an issue with the SSL of the website.Using ssllabs to check it is currently showing that im using an EC 256 bits (SHA384withECDSA) even though under plesk it is configured as an RSA 2048 bits (SHA256withRSA).I am using cloudflare and an origin certificate.Everything is installed on plesk with private key and origin certificate and also Ca certificate.The issues are two at the moment: First i like to use an rsa certificate instead of ecc becase of support for older browser, second it is showing that only 2 certificates are installed with only 2 (1805 bytes) therefore many viewers who are visiting from older browser are having ERR_CERT_AUTHORITY_INVALID. I have tried generating the certificate from cloudflare more than 10 times and switched 10 different origin certificates but im having still the same error. Can you please help me out ?

You would need to be on a paid plan for RSA key exchange. See the docs on browser compatibility.


Im actually under a paid plan on cloudflare,Is there anyway you could tell me how to change it to use rsa only ?

Is it by any chance, a Google Trust Services certificate? Or another Certificate Authority?

I have already downloaded the rsa ca-certificate which was under this cloudflare url: [Cloudflare Origin CA](

Anybody can please help me out clearing this issue ? As cloudflare isnt responding to my ticket since 5 days.