E-Mails from [email protected] in the wrong language

I received an interesting looking Newsletter from [email protected]

It is however not in the language set on the communication preferences pages. Please use the user’s settings to determine the language of emails instead geolocation.

2 Likes

Sorry about that, I have raised this for the team to review, thank you for the feedback.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.