E-mail obfuscation will not work despite correct setup

Email Address Obfuscation is not working on my domain:

Hello,
I’ve set up e-mail obfuscation on my site, but when I check the source code the email is visible. I do not have unnecessary spaces between “mailto:” and my email. I also set up the code correctly, the emails are in anchor tags.

I am not sure what’s going on here, any help is appreciated!
Thanks for your time

It’s not in an “a href” tag. It’s in a “a class” tag. Try switching around the tagging.

Thanks for your response, I switched the order of tags, but it still wont work

If I had just that line of HTML in its own file, it didn’t obfuscate, but if I put it in a standard HTML5 template, it works. There must be something about your document that’s incompatible with this feature. It also looks like it’s switched back to your original format on your site.

That’s very interesting…
But what’s funny is that this only started happening when I changed my domain (and yes, I also changed everything necessary in Cloudflare)
In my previous domain, obfuscation worked perfectly… So it can’t be the code

To include additional information: I recently switched the main domain of my site to federicoarboleda.com, and am currently using the old domain as a “parked” domain (fede.place). It redirects all traffic to the main domain. Both are on my Cloudflare dashboard, and both have email obfuscation enabled. However, the feature only worked when my site had the previous domain. Once I added the new domain, it stopped working. I have included some images of the setup.
If the code doesn’t seem to be the problem, as @sdayman has pointed out with his useful test, then I’m guessing it’s something to do with this domain change. I already tried unassigning the “parked” domain in case there had been some issue with having two domains point to the same page. However, this did nothing. I also tried disabling obfuscation on fede.place in case there was a conflict in having it on for both. This also did nothing.

I am truly stuck, and whenever I try to contact Cloudflare directly, my issue gets insta-flagged as solved. Any help is deeply appreciated,
Thanks for your time




Fortunately I managed to solve this after a few days. It appears that there was an issue with the website database and having two domains. Updating the database and then removing/re-adding the secondary domain to my Cloudflare dashboard did the trick.

This might also be helpful.

2 Likes