Drv.tw with cloudflare CDN gives DNS problem and images are not loading

Hello guys,

I have been struggling lately to try setup a simple html/css/javascript website on drv.tw using cloudflare CDN.

The hosting is working somewhat but there are mainly two problems that I can’t seem to figure out despite that I find quite a lot on here and google when I have been trying to resolve it myself…

Occasionally I get Cloudflare Error 1016 “Origin DNS error”. I don’t know why I only get it sometimes and other times it works…

The last couple of days I also started to get problems with that none of my images are loading on the site. Before it worked flawlessly. It means that images are not loading when I try to visit my site. They show up as broken.

If I right click on the broken image icon, I can choose “Open image in a new tab” and perfectly view the image… hence I figure that the link is not broken. I am not sure why I started to get this problem without changing anything!!

Here are my cloudflare DNS settings:

I think the Error 1016 might have something to do with the following that was posted on here by @epic.network in another forum thread:

You have created an unresolvable situation by creating a CNAME for your apex domain that points to the www hostname while simultaneously creating a CNAME for www that points to the apex domain.

You have created a paradoxical loop: www.example.com → example.com → www.example.com → example.com → www.example.com and so on, forever.

One of the two needs to have either an A or AAAA record, or use a working canonical name in another domain.

But I am not really sure what he means or how I should add the A or AAAA record to try if it works…?

Any feedback would be highly appreciated, thank you!

Here is how my broken images that wont load are showing up on the site:
webbroken

Guys, any ideas? Thanks!

Ok I have resolved the image issue… had to specify the image source with a direct special sharing link format from Google Drive. It has to look like this: https://lh3.googleusercontent.com.…

It is not possible to use the default img\image-name.png search path… need to be that kind of special direct sharing link.

The DNS is still not working.

Can anyone share some input to how I shall setup the records to avoid the Cloudflare Error 1016 “Origin DNS error”?

Thank you!

Hmm I have played further with this 1016 error.

If I turn off the “Proxy status” and uses DNS only for my root and www. records, the 1016 error appears to disappear… at least I didn’t have it for couple of hours now since I turned off the proxy.

What does this mean? I really want to use the proxy feature, hence I need to find some workaround.

There is no input from the forum on these issues???

You’ve obfuscated everything so no-one can check. You’ll need to give the domain name at least, and the original screenshot of the DNS records would help.

Thanks for your input!

Sorry, I can’t share the domain name. I don’t want this issue to show up on Google when my website is googled.

But the following doesn’t say something to an expert what might be wrong (?):

  • Error 10 16 appears to disappear when proxy status is switched off to only dns mode
  • Error 10 16 appears OCASIONALLY when the site is proxied
  • After I switch to dns only and then switch back to proxied, it appears like the Error 10 16 happens first after couple of hours.
  • If I go to www . whats my dns . net and try to resolve C NAME for www . my domain . com, it doesn’t resolve. No matter if I try this when the 10 16 error appears or when the website is functioning.

Basic DNS settings:

  • C NAME record for www pointing at xxxxxx . on . drv . tw (proxied)
  • C NAME record for my domain . com pointing at www . my domain . com (proxied)
  • TX T record for www pointing at DRVTW = xxxxxx . on . drv . tw
  • Page rule for my domain . com / * —> Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https : // www . my domain . com)

I am trying to host for free but I am starting to give up. But before I give up, I would like to know what is wrong to instead go and buy a premium hosting service.

I am sorry I have to split up the text above with “spaces” since the forum has some rule saying that I only can post 4 links in a single post…

You can put the domain name in here…
https://cf.sjr.org.uk/tools/check
…then I can see it, but no-one else will be able to help.

That seems like a great tool but I am not sure what to do with the shown errors for my domain. I sent you a link to my result on the contact form on your website. Please don’t share the domain or link to the results here…

Let us just discuss the problem/solution to allow for future Cloudflare users to find it.

Any suggestions?

Your site gives a 1016 error. It means the target of the www CNAME doesn’t resolve. You need to check that you have entered the target correctly and that it is valid.

When I visit the link in the www TXT record, it reports The link you visited is not valid.

I have entered the target as per the DriveToWeb tutorial.

To make it resolve I need to add the folder name on my drive after the adress: https://xxxxxx.on.drv.tw/www.mydomain.com/

But that is not how they say it should be entered. According to the documentation it should be entered like this:
TXT record for www pointing at DRVTW=xxxxxx.on.drv.tw

Without this part: “/www.mydomain.com/”

I am very confused.

Now when I tried to enter the website I didn’t get the 1016 Error. Any idea to why it happens only occasionally?

Should I update the TXT record to (?):
www pointing at DRVTW=xxxxxx.on.drv.tw/www.mydomain.com

Hm… I did some trial and error.

I changed to these settings:

  • C NAME record for www pointing at xxxxxx.on.drv.tw/www.mydomain.com/ (proxied)
  • C NAME record for mydomain .com pointing at www.mydomain .com (proxied)
  • TX T record for www pointing at DRVTW = xxxxxx.on.drv.tw/www.mydomain.com/
  • Page rule for mydomain .com/* —> Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https:// www. mydomain .com)

It didn’t work.

Then I tried this:

  • C NAME record for www pointing at xxxxxx.on.drv.tw (proxied)
  • C NAME record for mydomain .com pointing at www.mydomain .com (proxied)
  • TX T record for www pointing at DRVTW = xxxxxx.on.drv.tw/www.mydomain.com/
  • Page rule for mydomain .com/* —> Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https:// www. mydomain .com)

Now it seems to work. When I use your website to validate, the previous errors are gone. All seems to be OK.

Can you please check and confirm whether you agree with me or not?

Thanks!

I don’t know, maybe someone who uses drv.tw will comment.

The only other thing to try is to have the CNAME as “DNS only” and bypass Cloudflare. This is often necessary with a CNAME to an external host as they need to see it to validate it.

Please check my previous post, I think it may be working now.

I got a few 1016s in a browser, the checker is working. Now seems to work in the broswer. Leave things alone for a while to see if everything is stable.

I went to the Cloudflare caching panel and “purged everything”. After that I am back at square 1.

Now when I try to visit www.mydomain.com I am just landing directly on https://www.drv.tw/

And now your tool is again showing errors after my cache purge…

All what I did was to purge cloudflare cache and reset my own browser cache :frowning:

Here is the DriveToWeb tutorial for CDN: https://docs-of.drv.tw/how-to/using-cdn/

I can’t see what I am doing wrong…

The TXT record for www, you have DRVTW=xxxxxxxxxxxxxxx.on.drv.tw/www.example.com/. According to the instructions you linked to, it should only be like this… DRVTW=xxxxxxxxxxxxxxx.on.drv.tw

Yes that is how it was originally but if you see here above I added /www.mydomain.com/ to make it resolve after your feedback.

For a moment it worked until I purged all cache.

If I remove /www.mydomain.com/ we are going back to the original setup with occasional 1016 errors. Better than the current status I guess…

Just seen this…

You need to remove /www.mydomain.com/ from this CNAME. CNAMEs must point to hostnames, not links, so this must be only xxxxxxxxxxx.on.drv.tw

1 Like

Yes I did it now but you realize I added it recently only as a reaction to your previous input to try if something would change.

So even now when it is removed, we are back at occasional 1016 errors.

You agree?