Dropbox stopped syncing after enabling Gateway

Hi there
I don’t have any policies turned on. Attached screen is my only settings turned on. Would someone be able to give some tips?

Hi, I’ve not use Teams Gateway.
But after looking on your screenshot, my hunch tells me that it’s the TLS Decrypt options that broke Dropbox.

A quick google confirms that Dropbox Client indeed uses Certificate Pinning to check if the connection has been “tampered” with.
Secure, scalable infrastructure - Dropbox Business (Certificate Pinning Section)

With TLS Decrypt enable, you basically instruct CloudFlare to “tamper” your connection between you and Dropbox. This “tampering” has changed the SSL Certificate, which will makes Dropbox Client refuses to connect out due to Certificate Pinning check has failed.

I believe if you turned off TLS Decryption, your Dropbox client will be able to resume connection.
Or, you can just add a HTTP Policies against dropbox domains and set the action to do-not-inspect.
https://developers.cloudflare.com/cloudflare-one/policies/filtering/http-policies#actions

After a quick restart of your dropbox client, it should resume syncing.

Thank you so much! This works for me.

Created a policy. However, precedence is important. I needed to drag it to the TOP of the policy page, so that ideally it should respect that policy first. It didn’t work for me when it’s at the 2nd or 3rd.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.