Downloaded PDFs cannot be opened after domain transfer

Hi I am having a problem with downloaded PDF files, they cannot be opened using Adobe Reader (The error message: Adobe Acrobat Reader could not open ‘1804-PDF Galley-6510-2-10-20211206.pdf’ because it is either not a supported file type or because the file has been damaged (for example, it was sent as an email attachment and wasn’t correctly decoded). ; while in Google Chrome, the error message is “Failed to load PDF document.” The files cannot be opened either in Android. But, the files can be opened in iPhone, Mac Preview and Mozilla. The PDF viewer is working well in all devices. Here I provide you the link of one of the articles for checking: View of Correlates of evidence-based nursing practice among nurses in Saudi Arabia: A structural equation model | Belitung Nursing Journal

The PDF can be opened in all devices before uploading to OJS system, or when downloaded from dashboard. But not downloaded PDFs from public URL (as the URL above).

Note: The problem happens since the domain transfer was completed. Really need your help!

Thank you so much. Appreciated!

Anyone can help me with this, please? I have tried to set a Page Rule to bypass cache level on PDF, but it’s not working.

That domain is not currently proxied by Cloudflare. It still doesn’t work?

1 Like

Yes, it still doesn’t work.

In that case, it’s not due to Cloudflare. The connection is going directly to the server. Unless your DNS record here is incorrect (highly unlikely, as the site works), Cloudflare is not involved in this issue.

Thank you. Let me check with the hosting.
However, I found this in the Cloudfare. “API Request Failed: POST /api/v4/accounts/86da44863f4504c9838dce05a588ba87/intel/attack-surface-report/checkers/spf_check (502)”.

Will it be connected to the issue?

Nope. Once a browser gets the IP address of your site, Cloudflare has nothing to do with what’s going on with your PDFs.

Good to know. Will keep you posted with the progress. Thank you

1 Like

Hi @sdayman

I am still unable to manage the PDFs. The DNS records in web provider and Cloudfare have been clearly set. Any possibility that Cloudfare changes the encoding type in the PDFs in the downloading process? Meta charset is set UTF-8 for all. Thank you for the help

Not a chance. The site is not proxied by Cloudflare. Whatever is going on is strictly between your host and the browser. If you want to totally eliminate any question about Cloudflare, I suggest you change the name servers to whatever your host set as your domain’s default.

Thank you for the quick response. Appreciate it! I’ll keep searching for the solution of the issue.


Hi @sdayman, you are right. Nothing to do with Cloudflare. Just finished trying it at the local host. Cnce I upgrade the web to the latest version of OJS, it is all solved. Thank you for all the answers. Sorry if I was being straightforward.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.