Don't know what to do with DNS


#1

I’m troubled with my website DNS. I’ve linked my domain (domain.com) to cloudflare. My domain is “neuropsicologia.online”. I’ve been using this domain redirecting to a service my company contracted which I had to add a CNAME and a A registry in my DNS. The CNAME links my domain www to the service, they use the website saas.eadbox.com, and the A registry links with their IP. We decided to change this service to a subdomain (ead.neuropsicologia.online) and redirect the www to a new website hosted in a aws server (18.223.64.33). The change to the new subdomain worked well, but the main website don’t. I created an A registry that points my domain to this IP and deleted the CNAME registry. When I delete the CNAME, my website goes offline. I waited an entire day for propagation, but it doesn’t work. Does anybody knows what I’m doing wrong?

Thanks for advance and I’m open to give more detalis.


#2

Generally speaking, your DNS settings look alright. As you are proxying all requests go through Cloudflare and the connection between Cloudflare and your server is the problem, as Cloudflare cant connect to your server.

First thing to check would be what your TLS/SSL mode is. Is Flexible or one of the two Fulls? Also, is your AWS server configured to serve HTTPS?


#3

It’s the first Full, without strict.
AWS is configured to serve https normally.


#4

Now the A record worked! But the site is changing the name to the IP address. I think I need to insert a CNAME to resolve this, but cloudflare does not accept the record www - neuropsicologia.online (@)

Does anyone know what I have to do?


#5

Nothing to do with a CNAME or even DNS. Your server is receiving the request but instead of simply returning the site it sends a redirect to itself with its IP address. Thats something you will need to fix in your server configuration or possibly Wordpress. You probably specified somewhere instead of the hostname the IP address.


#6

Does your www record point to your ip or neuropsicologia.online? I tried to add a CNAME with a value of neuropsicologia.online, worked ok, can you attach a screen shot of the “not accept” part? (did you have an existing CNAME at the time?)


#7

Printed all records that referes to www or the domain. This is the error I’m getting when I try to add the CNAME


#8

Delete the existing www A record and then add the cname


#9

Added but still malfunctioning. Now I have the www pointing to neuropsicologia.online (CNAME) and neuropsicologia.online pointing to the IP.


#10


#11

Will check on the server and wordpress. Thanks


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.