Domainname(.)com does not work but a sub-domain does, please help

I host my site with Hostinger and changed my default nameservers to Cloudflare’s name servers. However, my main domain is no longer available after I changed the defaults but a subdomain is available. When I change the nameservers back to Hostinger’s defaults, my main domain works and the sub-domain doesn’t, it is like they flip flop. Cloudflare does show an A record of my main domain with an IP address that has a status of ‘Proxied’ but it is still not working. I pinged my website and used the IP from the ping as the A record IP but still no luck. Any other suggestions to try for this?

By no longer available, what error are you getting?

Here is what I am getting

You probably want to checkout

Step 4 is probably best

Enable Full or Full (Strict) mode. Learn more about all the SSL options available through Cloudflare.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.