Domain will not resolve on Cloudflare DNS

This is my first post here and I’m just a user of Cloudflare DNS. The issue is that when I use Cloudflare as DNS on my network (router) a certain domain doesn’t resolve. When I use default Comcast DNS or Quad9 the addresses resolve. The host that won’t resolve is:

It’s used to update NBC podcasts but doesn’t work with Cloudflare DNS. All other podcasts update without problems, but the NBC ones don’t.

If this isn’t the right place or way to report such a problem please let me know what to do or where to go.

I experience the same, but haven’t tried another DNS.

It looks like there’s a CNAME chain in place:

Which resolves to an A  record:

This doesn’t violate any specs, but is not best practice as it’s inefficient. I’m not sure yet why there’s a 404 error though. Still poking around.

Are you using DNSSEC, and does the site resolve if you disable it, but still use

This “may” be the issue. has published DNSKEY records, but the Amazon-hosted nameservers haven’t.

I’m no expert, but there could be a DNSSEC misconfiguration that’s causing the issue. The main site is partially loading for me too. I cannot disable DNSSEC right now to test this theory, but maybe someone else here can verify with DNSSEC disabled.

I’m just a user and do not know if I am using DNSSEC or not. I’m on a Netgear Orbi system with default settings except for having set as DNS. IPv6 is enabled and use Cloudflare as well

Sorry about my ignorance in these matters. I will read up on it for sure. But in the meantime I would like to be able to reach NBC without setting another DNS on my router or device.

As temporary solution, you could try setting Quad9 as a secondary DNS provider in your router settings. That should allow failed DNS querires to fall back to Quad9.

That was a great idea except for that my stupid Netgear Orbi router only has two DNS entries. Could or should I do and for now?

Yes, the second entry should be Quad9. Please advise on the results. Thx

You can use this to help verify your settings:

I have been looking into this some more. Just changing second DNS to Quad9 did not work. What did work was switching “everything” to Quad9. both IPv4 and 6. Maybe this is an IPv6 issue? Anyway, for now I will just stick with Quad9 since it works until I have time to investigate and test further.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.