Domain transfer not working - SSL Pending

After going back and forth with different support desk, nobody is able to help me so I am hoping this community can.

I’ve been trying to move a domain because my website has changed from Lightspeed CMS to Shopify. After changing DNS records to the IP adres of Shopify and making it the primary domain (www.wellofwine.nl) I was expecting it to work, but when I go to the domain wellofwine.nl I keep being redirected to my old website (hosted on Lightspeed) while the IP adres is pointing towards Shopify. Even my collegae who is an architect couldn’t figure out what the reason for this is.

In the backend of Shopify the SSL says it pending. Shopify mentioned that Cloudfare is stopping the SSL certificate because Cloudfare headers are stopping this. Is this indeed the case? If so, how do I stop this?

As a test I’ve added blabla.wellofwine.nl to Cloudfare and made this the primary domain in Shopify, it instantly provisioned the SSL certificate and worked… but when changing the primary back to wellofwine.nl its pointing me back to the old website.

Hoping anyone is able to provide help, so we can finally launch our new website.

Many thanks,
Sam

Please ask them which Cloudflare headers are stopping this. There are Transform Rules here that can modify request and response headers.

https://developers.cloudflare.com/rules/transform

Thank you for the response.

So far they are not able to tell me unfortunately… Do you also see that if you go to the wellofwine.nl its redirecting? What do you think could cause the SSL certificate not being validated?

It redirects to https and www, but the page is displaying from Shopify’s IP address.

Yes but the page your displaying here is not the correct one. This is the old backend which is not Shopify but Lightspeed. Which you should be able to find in the code somewhere: [webshopapp.com]

The homescreen that should be showing up looks like this:

And that puts us back to the header issue. Maybe Shopify can tell you more about this header, or what you specifically need to do to get your site working on Shopify.

Which Support desks have you been in touch with?

Okey I will then go back to Shopify again and hope they can help. I’ve been going from Shopify to previous hosting provider (flexweb) to Cloudfare to Shopify to flexweb back to Shopify, nobody at Shopify seems to be understanding the problem which is making it really hard to find a solution.

this is what shopify says now:

will need to ask them to specifically:

remove the SSL/DNS configurations by logging into their cloudfare account or by contacting Cloudflare support to get their help in removing the old configuration meaning the old SSl and DNS configurations

You had your domain set up through Cloudflare prior to this move to Shopify? If so, then youcan do the SSL part. I don’t think removing the DNS configurations is safe, because you’ll lose DNS for your Shopify site. I’m not sure why they would recommend that.

You can remove SSL from the SSL/TLS page’s “Edge Certificates” section. Scroll to the bottom and Disable Universal SSL.

I am having the SAME experience with my new Shopify store and my domain. lithiumpros.com was on WordPress/WooCommerce using CloudFlare Pro. Its been a week of back and forth. I feel like a ping pong ball.

There really needs to be a better instruction sheet for this. Many are having the same issues.

The OP looks likes they’ve never been on Cloudflare before now, according to their name server history.

Your domain has been using the same two name servers here for five years. Have you tried disabling Universal SSL, as per my previous post?

Just did…I guess it wait and see?

And this is what Shopify says:
Ah ok thanks so much for confirming that - it looks like that may be where the issue lies… Your Cloudfare certs maybe taking priority over Shopify’s settings
Since Shopify’s networks are served via Cloudflare, and request for a Shopify store goes through Cloudflare, if there is a personal Cloudflare configuration (one associated directly with a Cloudflare account) it takes precedent over our own Cloudflare configuration. You will need to contact Cloudfare to resolve that…

Please be assured that this is what is returning from our checks - a SSL certificate can’t be provisioned by Shopify as there are Cloudflare headers preventing this. Only Cloudflare can remove these headers which they can do if you contact their Support team.

So I am hoping your suggestion fixes the issue.

So there’s no more Edge Certificate listed at the top of that page?

And are all your DNS records set to :grey: DNS Only?

They really need to stop going on about headers if they can’t say which header(s) they’re talking about. Keep bugging them about that because it’d be nice to get to the bottom of this.

Imagine contacting Cloudflare Support and telling them they need to remove some header(s), but you can’t tell them which one(s).

I hope so, too, because we’re really getting nothing actionable from Shopify.

Confirmed: No Edge Certificates

1 Like

I believe there was another user who properly prepped their Cloudflare account. Once that was done, Shopify did a remove/re-add of the customer domain on their system and it started working.

Oh, from another poster on here, I saw something about WP Engine (WordPress) referencing the old site. He removed a reference or header there (must double check, I’m out of my element now.) That resolved this for him.

So I’m running down that possibility too with my old web developer.

1 Like

Hello, your source code is hosted with Shopify, Inc.?, If so, the ideal is to use their NS, not Cloudfare’s, apparently it can happen:

  1. The IP 23.227.38.74 belongs to Shopify, Inc.; using AS13335 - Cloudflare, Inc.

  2. The DNS results to the ip 23.227.38.74

  3. There is a 301 redirect from https://www.wellofwine.nl/ to www.wellofwine.nl/nl/

I suggest you:

  1. Use the DNS of Shopify, Inc.

  2. Configure the Cloudflare service offered by Shopify, Inc.

" f you turn your grey clouded Shopify store back to orange cloud in the Cloudflare DNS app, site visitors will experience a 10xx error. To fix this error, turn your orange clouded domain back to grey cloud in the Cloudflare DNS app. "

  1. Check redirect rules in Shopify and in your .htaccess config file.

I’ve not seen name servers offered by Shopify. That article doesn’t show any, either.

The default ones, those of Shopify.

You can reset the DNS settings, if necessary.