Domain Transfer: my domain doesn't appear on 'Select domains to transfer' page

My domain does not appear on ‘Select domains to transfer’ page.
I already added the domain to Cloudflare.
I tried to transfer and cancelled it because I found that I forgot to disable WHOIS protection.
After that, I tried to retry transfer but my domain does not appear on the page. so I can’t do anymore.

please tell me how to solve it.

What is your domain? Not all TLDs are supported.

sorry I can’t tell the full domain name. TLDs of my domains are .com .xyz
Is it available?

1 Like

Hi @t_t,

.com and .xyz are both supported by Cloudflare. It is difficult for us to say what the issue may be without the domain as there are various restrictions.

If, when you go the the domain registration page, where you see a list of domains that can be transferred, you scroll down and click “Show X domains unable to transfer”. You should then see those “already on Cloudflare” and those “Unable to transfer”, this will show a list of your domains and should give the reason that they cannot be transferred.

2 Likes


like this capture, there is no domain shown.

That’s strange, are you definitely in the right account with the domains in?

Just tried it and mine shows all domains there fine.

Edit: Mine shows what yours does when I first open the page, but after a few seconds, my domains all appear.

First time, I added the domains, they appeared. After I pushed ‘Cancel and Retry’ button, I tried to retry transfer. but there is no domains shown.

I can only suggest that you contact support as I see mine fine.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. Please give Support the complete details and link to your Community post. Here’s a bit of background on Cloudflare Support for reference:

Please share the ticket number here for reference so the mods can tie up your post here and the ticket.

Thank you, @domjh @sandro
I requested a support ticket. The ticket Number is 1738508.

1 Like

Those domains are pending name server update, @t_t, that has to happen prior to transferring the domain to Cloudflare registrar, good tip here, Community Tip - Fixing “Pending Nameserver Update” .

1 Like

Thank you, @cloonan

I thought changing nameservers han nothing to do with my domain register&transfer.

I will change it.

2 Likes

This is the solution. You have to add your domain to Cloudflare and update your nameservers on your old host to be able to transfer it to Cloudflare. They should be more clear about the steps for this process. @Cloudflare are you listening?

1 Like

******* Please Please Cloudflare support, update “registrar transfer” instructions with this info. I have wasted several hours trying to figure this out. This should have been few min task *****