Domain transfer error to cloudflare domain registration

When trying to transfer my domain to Cloudflare domain registration, it is showing error: Something went wrong Your payment has been declined. Please check with your payment provider or try again with a different payment method.

Hi @host1946,

Sorry about the issue. Can you check that the payment method you added is correct and working and that the payments haven’t been declined there? That would suggest to me that the payment from your provider was declined, they may be able to offer some help / advice on why that was.

The account has enough money. The billing info is correct. I tried with 2 bank accounts’ debit cards, one is VISA and other is Maestro. Both shows same.

Strange that both had the same error, are you able to contact the card provider(s) to see if they can tell you why the payment was declined?

It did not look like bank issue. I added money today morning to the said account.

Have you seen this article?

https://support.Cloudflare.com/hc/en-us/articles/218344877-My-payment-failed-what-do-I-do-

Let me check with the bank if it’s on hold. I highly doubt that as the same happened for 2 bank Debit cards.

1 Like

Tried paypal. same error. I give up.

Sorry for the issues, if it still doesn’t work, I would advise contacting support:

To contact Cloudflare Customer Support, login & go to https://dash.Cloudflare.com/?account=support and select get more help. Please give Support the complete details and link to your Community post.

cc @cloonan

1 Like

And please share the ticket number here @host1946. Sorry for the issue.

1 Like