Domain still resolves to old CF nameservers IP, not to new ones

My domain cherada.com (Hosting Server IP is: 192.254.199.108). It has WordPress and has been using these CF nameservers since 2019:
ken.ns.cloudflare.com
roxy.ns.cloudflare.com

I did a SSL cert change and it didn’t resolve for HTTPS, I removed domain from CF and once I solved that issue went to add again the domain to CF.

Now it show a blank page that says “No Index.” instead of showing the WP theme homepage.

So, I performed the following tests:
-proxy option was disabled, the DNS is still resolving to the CloudFlare IP it had before I removed the domain from CF.
-Created a test file and accessed the file, but failed to access
-cleared the cache in the CloudFlare, issue persists
-Not able to access the test file.

This is what this test site says about this:

Hosting provider says this can only be solved with CloudFlare support, but ticket option is not available for the moment.

What do you suggest can be done?

Your site works with HTTP, but not HTTPS. This indicates there’s still a problem with the certificate on the server.

This topic was automatically closed after 31 days. New replies are no longer allowed.