Domain still goes to previous server / hosting provider

I moved to Cloudflare. It scanned and imported all A, CNAME, etc. records correctly. The domain was connected to InfinityFree hosting provider. All good, it was working correctly.

After setting up my site on Oracle VPS I changed the IP address on A, CNAME, etc, record to point to new server however it’s still loading the site from previous server / infinityfree account.

I deactivates all relevant records, domain, etc. in my InfinityFree account. “Purged everything” in Cloudflare. It’s still trying to load from infinityfree server.

DNS checker shows the Cloudflare servers so no issues there looks like cache is not cleared in Cloudflare.

  1. Tried whatever suggestion I could find in this forum nothing works
  2. “purged everything” couple of time still same issue
  3. Tried DNS only (no proxied via CF) still same issue

There are two sub-domains I created and they are pointing to new server correctly. One difference is I never had these sub-domains they are totally new and created in CF.

Sent an e-mail but rcvd a response that ticket is closed, upgrade to business plan.
Hoping someone will be able to help in the community.

Ticket number - 2616282

Thanks in advance.

I’d try Troubleshooting Custom Hostnames / Cloudflare for SaaS when moving provider

Also, make sure your encryption mode is Full Strict.

Though, if you have the issue when DNS is not proxied, it shouldn’t be a Cloudflare issue.

What’s the domain?

domain is -

encryption mode is Full Strict.

Is this not the correct site?

It’s the correct site.

When I try it - it takes me to
According to InfinityFree knowledgeBase article they show that when domain propagation is in progress and per that article it should works after 72 hours.

I cleared browser cache, used incognito mode, few different browsers, vpn, etc. still same suspended domain page all the time.

I did observe that sometimes it loads the page that you are seeing then when I click refresh it immediately takes me to
Could you please refresh it few times. Thanks in advance.

Maybe something on your local network is overriding DNS, check that.

The site itself is loading fine however. It’s about 8 KB, the same you are getting at

I would pause Cloudflare for now and make sure everything loads fine. In that way you can make sure Cloudflare is not involved.

All right, so we can exclude the issue of you having more than one origin configured.

Anyhow, this will be either a local issue or one with your server. As far as Cloudflare is concerned, the right content is loading.

As I mentioned, it’s really best to pause Cloudflare first and debug your issue and once your site loads for you, you can unpause.

It’s working now. I think it was local cache or something. I used a browser that I didn’t used before and the site loaded correctly.
It’s now working in other browsers that I tried before.

Thanks, sandro. Appreciate it.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.