Domain responding with 522 error

if I go to the site via the IP set in the DNS settings, it works fine but if I go to the site using the domain I get a 522 error.

Any ideas what could cause this?

I would ask your host to whitelist the Cloudflare IPs.

We host it ourself on a server, so no IP’s are whitelisted. The site was working about 1-2 weeks ago and we tried to access it a few days ago and got the 522 error but never got round to fixing it.

Have you checked out the other troubleshotting steps in the linked article? Community Tip - Fixing Error 522: Connection timed out and also:

Yep, we tried anything possible in there with no luck. We host some other sites that do not use Cloudflare and they are working fine.

Hmmm, those seem to cover everything I would suggest! Have you tried contacting support with a RayID or two?

Alternatively, someone else here may be able to offer some suggestions.

How exactly do I do that?

You can find the RayIDs on the error page as highlighted here:

Then you could login to Cloudflare and then contact Cloudflare Support, click the ‘Get more help’ option at the bottom.

Make sure you give them as much detail as possible and explain what you have tried.

Whats the domain in question?

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.