Domain registration not working (403)

I have successfully registered domains on Cloudflare a few weeks/months ago.

This week I can’t get it to work. When I click on purchase, I get 403 in the console for my call and the screen displays: “We’re sorry, there was a payment error. Please check your payment details, or try a different payment method.”

The CC I am using is the one that gets billed monthly and is valid.

I have tried another card, also doesn’t work.
I have tried buying without the Business mode selected and removing my tax number, doesn’t work.
I have tried another browser in case a JS was cached and causing the issue, doesn’t work.

  1. (I am of course logged in to do those attempts.)

Can someone please move this thread where it will get more visibility from people that could look into the issue or point me in a direction that will help resolving my issue?

Hi there,

Do you have a ticket open with us? Please share your ticket number here so I can look further. Please also send me a screenshot of the page showing the 403 error and the steps you took that led you to this 403 error.

Thanks,
Purnima

Thank you for replying, purnima.

I’d prefer to avoid sending a screenshot here of the fields filled with my personal information. Fields have values I have been using in the past (my adr, phone and such). I also tried with another browser (Edge with no extensions installed, tried another credit card, tried both business and personal registration), any combination of those lead me to 403.

I don’t have a ticket opened, and would be more than happy to open one if you can please point me in the right direction, I was under the impression that I couldn’t open those with my plan.

Hi there-

The issue seems to be a payment issue from your description. Please open a ticket with [email protected] and I can assist you further.

Thanks,
Purnima

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.