Domain Registration ERROR URGENT

When I tried to upload my domain, it shows this error. What can I do?
Plase I need help. SOS

Hi @user16922,


I understand what you are saying, but I did not violate any of the terms, I don’t have a storage website, I have a marketplace and I can’t wait a whole week. Any other advice? Is there any mail support to contact directly with cloudflare?

Did you have the site on a Cloudflare account recently and it was then removed?

If so, you should have received an email from Trust & Safety where you can follow up.

No, this is a new domain I registered yesterday.

Please email [email protected] explaining the issue and the fact that you just recently registered the domain.

Thank you, I will mail them.

1 Like

Hello again, I haven’t have response from the mail I sent.

It looks like you were able to add the site to Cloudflare, as your WHOIS shows Cloudflare name servers for your domain.

No, I haven’t. I add those servers so CloudFlare could find my domain, because before I tried to add it and CloudFlare would say that my domain wasn’t registered.

That won’t fix the issue and opens up a security hole. You need responsive nameservers before you add the domain.

If you repeatedly tried to add the site with it not working, that’s probably why it has been temporarily banned.

It says, TRY LATER, so I do that. What should I do?

Meaning once you’ve fixed the issue or waited for your changes to propagate. Your zone has probably been restricted because of repeated attempts to add it in a short space of time.

You will likely need to wait for a while before you can add it again, when you do try make sure it has valid resolving nameservers.

I don’t understand. First, how much should I wait? And second, What issue should I solve? I am doing the same think I did with another domain, following the same steps. Why should I fix something? What have I done wrong with the domain?

First you tried to add the domain when it wasn’t resolving and second you set Cloudflare’s nameservers before adding the domain to your account.

Your domain needs to be working with nameservers that resolve before you can add it.


I don’t have name servers, so how could it possible be working with nothing?
I read in a forum that if Cloundflare didn’t find my domain I should put those cloudflare servers, so I did because cloudflare wasn’t finding my domain, and when I added them, cloudflare banned me, so what can I do please help

Where did you read that? I hope it wasn’t here because that is very bad advice.


I did it with my other domain, and it worked perfectly. Because I don’t know why, cloudflare doesn’t fine my domain registration.

Set up your domain at and user their name servers. Put DNS records in for the domain name and ‘www’ with an IP address of

Then wait a day before trying to add it to Cloudflare.