Domain redirectc always

Tests show that my domain redirect from http to https. I’ve server response 0,6-1,6 seconds or more. How i can solve this?

I’ve tried lot solution, contacted hosting for 1 year but nothing…

https://wheregoes.com/trace/20235631091/

% host giocone.com
giocone.com has address 70.40.216.191

Your domain is using Cloudflare name servers, but the hostname is :grey:, so any performance issues are directly related to your Origin web server configuration.

In Cloudflare, you can configure the http → https redirect using the “Always Use HTTPS” setting on the dashboard, but the hostname would need to be :orange: for that setting to work.

can you explain step by step?

1- I go on DNS
2- Which Proxy change? My hosting has told to put A and CNAME records as only proxy. In while I wait your reply, I add them again as proxy.