Domain points to wrong hosting and returns SSL ERROR

Hello guys. I made my first production level Django project it’s up and running on Heroku with no problems at all. But after I changed my DNS configuration on Cloudflare to remove old temporary hosting (InifnityFree) and add my new hosting (Heroku) website is inaccessible.
The problem is website is not accessible through SSL also http version points to old hosting.


WHAT I TRIED:

  • Deleted cache from browser
  • Purged cache on Cloudflare
  • Tried different browsers / devices / ISP’s

No luck so far. Also, even though I enabled Always HTTPS, I can still go to HTTP:// version of it. It’s been more than 10 hours since the DNS configuration (I’m aware that it may take up to 72 hours, but it’s not my first time using Cloudflare. It never took that long and it makes me worried about what is actually going on.


DNS CONFIGURATION:


(Sensitive info refers to DNS target that is being provided by Heroku, I just censored it for security measurements)


THE ERROR SCREEN FROM FIREFOX DEV EDITION:


ADDITIONAL INFO:

Domain : https://udemyfree.net
Backend : Django
Hosting : Heroku
Domain provider : Namecheap


Any help would be greatly appreciated, thanks in advance!

:warning: EDIT: Somehow website is accessible with VPN. Everything is working fine with VPN but even I use different ISP’s with different devices and different browsers in my region it doesn’t seem like to work.

#heroku #dns #https #error

Works perfectly fine for me on https://udemyfree.net/

1 Like

Hi and thank you, Kian. I’m aware that it works just fine in different countries, but the problem is, it’s not working in my country (Azerbaijan) for some reason. I did not set any IP block or etc, it’s quite strange behavior if you ask me. I can only assume that the problem is Azerbaijani ISPs don’t update their DNS, probably have to wait 72 hours (almost 16 hours already elapsed). Still not working as I write it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.