Domain not working without www

Hello, and thank you in advance

I have setup two domains with Cloudflare. Both with identical A and CNAME settings. One resolves perfectly without using www. and the other points back to my domain registrar. I double and triple checked everything. I’ve called my registrar and they say everything is perfect on their end, and the issue lies with Cloudflare. I’m sure if it’s an issue, but I’m also using Samcart where my sites are hosted. All settings on that end have been checked as well. I’ve tried recreating the Cloudflare domain entry process, and also tried redoing the CNAME record. Nothing seems to work. Any suggestions?

The two domains in question are:

  1. myhealthyretirement.ca
  2. happierhealthy.ca

Thank you,

Lou

Both behave the same for me. Non-www is not proxied and points to an IP address that shows a Rebel parked page. www is proxied and shows a site.

I suggest you Proxy the non-www entry and add a Page Rule to redirect it to ‘www’, like in this tutorial:

Thank you so much. I spent a lot of time trying to figure this out. Your help is much appreciated.

image002.jpg

image002.jpg

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.