Domain not resolving at all

I am currently hosting a web server at home on port 443. I bought the domain name off Godaddy.com and I have changed the name servers to the ones given by cloudflare.
These are my current DNS settings.

But all I get is

But CloudFlare’s speed test still works?!

I am afraid you havent. It still points to your registrar.

Much appreciated for the fast response!
I suppose my registrar is Godaddy, the one I bought the domain name from? This is what it looks like on their part:

Translation
Unable to view your DNS information because your name servers are not managed by us.

In that case it might take some time to actually take effect. Right now there are still the previous nameservers.

nslookup -type=ns dashing.no i.nic.no
Server:  UnKnown
Address:  194.146.106.6

dashing.no      nameserver = ns81.domaincontrol.com
dashing.no      nameserver = ns82.domaincontrol.com

That might be it. I’ll wait a few hours, perhaps a day and check back. (will update here)
Thank you!

Also, right now it wouldnt work anyhow. Your server is running on port 443, which is correct for HTTPS, however you are serving HTTP. You need to switch that to HTTPS and make sure you have a proper certificate in place.

Oh my goodness, I had forgotten about that! I switched my server’s port to 80, and tried to connect to the domain, and it worked! I will be switching to HTTPS later today, and I’ll remember to switch to a supported port after that too.

Much appreciated, and thank you for the incredibly quick help!

My recommendation

  • Configure your server for port 443
  • Install a valid certificate (can be a Cloudflare Origin certificate too)
  • If present, configure the firewall to only accept connections from Cloudflare
  • Set your encryption mode on Cloudflare to “Full strict”
  • Enable “Always use HTTPS” on Cloudflare
1 Like

And the nameservers have made it to the registry by now. They are now correctly set.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.