Domain Mapping to Zoho Desk


I ve trying to map my domain with zoho desk.

They request me to create two things:

First: A subdomain.
Second: A CNAME record with the same name of the domain pointing to

The problem comes when i have already created a subdomain via a CNAME record host: “soporte”, targeting: “” my actual domain.

Then when i want to create the CNAME pointing to zoho it says that the host name soporte already exist and does not let me creating the record.

How can i do it? There is any way of creating a subdomain with a different method?


You can’t have a CNAME that’s a duplicate of another subdomain entry. You would have to get rid of that other one first. Or pick another subdomain name for your Zoho Desk CNAME record.

1 Like

I have already erase the subdomain and change the name of the CNAME but i continue getting the error:

Make sure you’ve mapped the CNAME entry and linked it to on your domain hosting site.

This is how i am setting up right now:

Change the :orange: to :grey: … they are likely trying to verify that the cname points ot that specific host which can only be done for a :grey: record.


I have change both but still getting error…

Your ‘support’ CNAME points to your own domain. It sounds like you’re supposed to have it point to instead.

check the requirement:

I need to create a subdomain - I am doing that through creating a CNAME record named “support”, the name of my subdomain, pointing to (That´s how a learn to do it doing I+D). - Also i have to create a CNAME with host “support” (Same name as subdomain) pointing to The problem is that i can´t name both records as “support” because it is bringing an error.

This is the documentation:

I keep seeing the requirement that the CNAME points to, but your DNS picture does not show “desk” anywhere.


Ok i understand. I hace change it:

Also trying with DNS only.

Both ways does not work.

When i talked with zoho support, they told me that the host for the cname that points to should be the same as the host of subdomain. So that is my main issue.

1 Like

There might be some setting at Zoho to let them know which subdomain you’re using to point to “desk”. If it’s not working in DNS-Only (:grey:), you’ll have to work with Zoho to get this working.

I use Zoho desk on Cloudflare and CNAME can be orange cloud CF proxied without issue. Though I did verify with CF proxy disabled at first as per their documentation

Zoho Desk will not be able to validate the CNAME if your sub-domain is enabled for Cloudflare . We recommend that you disable Cloudflare ( ) until you verify the domain in Zoho Desk. Once verified you can re-enable it ( ) again to continue with the security protections.

what is exact error message and where is it shown ?

Ensure you only have a subdomain CNAME mapped to the Zoho > Setup > General > Rebranding > Domain Mapping page

Note from their documentation though

Custom domain mapping is not available on the Free edition.

You are using a paid Zoho Desk plan ?


That just means you create a single subdomain CNAME based entry. Not create a subdomain A record + CNAME. It’s a single DNS record not 2 DNS records

1 Like


And that cname record its something like:

CNAME: Host: Pointing: It should be “proxied” or “DNS Only”?

Nope. I am using zoho one license.

Make sure you’ve mapped the CNAME entry and linked it to on your domain hosting site.

Thats All

I have already fixed the problem!! Further explanation:

I have created a CNAME record:

Host: “Soporte” Pointing: “” DNS: DNS Only :grey:

i have mapped the domain: “” and zoho desk recognize it and give me information to create a new CNAME record. Did that, verify my domain and everything works fine!!

Thanks everyone for your support!!!


you can after verification, re-enable orange cloud proxy for the cname :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.