Domain is not responding

Domains are not responding. I get an error 522

Domain was working earlier on Sunday

Rod

May I ask did you checked any of the suggestion in the below article regarding the 522 error? Regarding Cloudflare 522 error, may I suggest you to try looking into below articles to troubleshoot the issue:

How about your domain name SSL certificate?

Before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Renew your SSL certificate using cPanel / AutoSSL / Certbot / Let’s Encrypt / Contact your web hosting provider.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

No none of this helped, but I found the error:

It was not in Cloudflare at all

I had removed two port forwarding on my router as I did not remember what they were for

It turned out that they were part of NGINX Proxy Manager

Sorry for the problems

Rod

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.