(domain) is not a registered domain

Hi guys, I have multiple accounts in Cloudflare and have registered more than 200+ client’s sites on Cloudflare till now. But from the last 3-4 days I am facing one issue. And I tried to add 3 different domain names and all are giving the same issue.

One domain I bought from Godaddy and the other 2 domains from Google Domains.

revsdetailingstudio.com.au = Google Domains
zenithcollege.com.au = Google Domains
mclarencollege.com.au = Godaddy

All 3 are facing the same issue. The Name server’s spellings are right as I have checked multiple times.

You can see here the DNS is pointing to Cloudflare but the Cloudflare is not letting me add the domain to Cloudflare for some unknown reason. Here you can see = DNS Checker - DNS Propagation Check & DNS Lookup

And here is the screenshot = Screenshot by Lightshot

I never faced this issue in the past, as i said, i am not new to this as i have added nearly 200+ domains in different Cloudflare’s accounts till now. So, i am confident that i am not doing anything wrong.

I have already read most of the articles on Cloudflare.

Example:1 = https://support.cloudflare.com/hc/en-us/articles/205359838-I-cannot-add-my-domain-to-Cloudflare-

Example:2 = Community Tip - Fixing Code: 1049 example.com is not a registered domain

I need help from the community. Does anyone know the solution to my problem?

I see that those three domains are using Cloudflare name servers. You were able to get this working?

Hi bro, it’s the same from the last few days. I have been getting the same issue from the laar 3 days.

Still the same issue. Never fixed till today.

But the domain has Cloudflare name servers. It shouldn’t have Cloudflare name servers unless it was successfully added to Cloudflare. Otherwise, it should still be on your own name servers. As a reminder, you should never change name servers until that domain is configured at the destination.

2 Likes

Hi bro, i do not know what exactly do you mean.

More info: i also tried to do add new domain via phone. On mobile phone too, i am getting the same error.

The issue is the cloudflare is not adding the domain to cloudflare.

I have added many domains to cloudflare in the past. And i am not doing anything different.

Everyday, i add a new domain to cloudflare for a different client.

From the last 3 days i tried to add 3 different domains from 3 different clients and none got added in cloudflare.

I never seen something like this before in the past.

Only cloudflare tech team can find the issue. And i am 100% sure that the issue is from cloudflare itself. But i do not know how to contact cloudflare tech support team.

Please see this screenshot. You can see it’s been 3 days since added the Name servers. And till today i have been getting this same error message on cloudflare when I try to add new domain to cloudflare which you can see in the given screenshot above.

Those 3 clients are looking trust on me + i habe waited for a few days + I do not know how 5o contact the right support person to inform him about thi issue in their system.

You what? Never ever do this! Someone who already has those name servers can hijack that domain. They can set their own DNS records to point to something that is not your client’s website.

Hi Bro, sorry, i am not understanding what exactly you are saying bro.

You are using way too shortcut language which is hard for me to understand.

Can you please make it simple? If you know where is the issue.

See the issue is in these 3 different domains which i mentioned in the first post.

Eeeey, bro! Wazuuuuuup? You gotta chillax man, ey, for real. Bro @sdayman gave you da real stuff. Check it out, bro. It’s cool, ey. :sunglasses:

1 Like

Was this reply for me or @sdayman ?

As I understood nothing.

It looks like you want to do the right thing. So here’s how you have to fix it:

  1. Go to https://dns.he.net
  2. Register for a new account
  3. Add those three domains
  4. Give them DNS “A” records that work for their website
  5. At the domain registrar for your domains, change the Name Servers to the ones at he.net. It may take up to 48 hours for the change to take effect.
  6. Then you should be able to add those domains to Cloudflare.
  1. Brother @sdayman , those domains were bought by my clients by themself. And added my name servers in their DNS sections.

  2. Do I have to use the dns.he.net website every time from now on if I want to add a new domain?

  3. Have I done any mistakes or something is wrong with Cloudflare’s system which is not letting me add a new domain to Cloudflare?

  4. Those 3 domains belong to 3 different clients. So, I will have to call them manually tomorrow and try to add them on dns.he.net. I have no idea what that is but will study it.

More info:- You also also see that if we check the name server on any website, it says/shows the right name server of my Cloudflare account. But the issue is only with Cloudflare which is not letting me add any new domain to its platform. Do you know someone from Cloudflare’s team so that you can show this ticket/issue to the team? Because I am 100% sure that the issue is not from my end and I do not want to add any 3rd party tool like dns.he.net to solve this kind of issue everyday.


Brother @sdayman , I just created the account on that website + added the domain name. Now, should I go to Google Domains and ask my client to change the name server from my Cloudflare’s name server to = dns.he.net?

Or have I not understood you yet?

If I have not understood you please correct me, brother. I really need your help to get this issue solved permanently so that next time when I add any new domain to my Cloudflare’s account, I do not see this issue again. Currently, in my Cloudflare’s account, there are nearly 55 domains already.

I am one another Cloudflare’s account where I have nearly 100 domains of clients.

This is the main issue/error given by Cloudflare = revsdetailingstudio.com.au is not a registered domain. But you know that it is registered and pointing to Cloudflare too.

I found a video on YouTube which I think is related to the same issue I am facing but I am not sure. Here is the link = Cloudflare Website Issue | Solved!!! | 100% Easy | Fixed - YouTube

And I can not leave or stop using Cloudflare, and nearly every day I have to add a new domain to my Cloudflare account. So, will this issue stay forever in my account or is it a temporary issue? Can any please show me some light on this issue about why all of the sudden I started getting this issue?

The issue is pointing the nameservers to Cloudflare before you add the domain, that has been the same for a long time and I doubt will change soon.

The domains need working nameservers elsewhere, this could be your registrar or host’s default nameservers or a 3rd party like dns.he.net as @sdayman suggested.

As long as the domains resolve with working nameservers, you will be able to add them.

Hi @domjh i understood a little.

Bro, i want to use cloudflare’s DNS not my own servers dns.

I have been doing the same thing from the last many years and never face issue in the past? Then all of the sudden what happened?

If i use he.net or my own name servers then how to add cloudflare’s dns?

The point is to add cloudflare and you guys are asking me to add some other dns.

I am not understanding that @sdayman and. @domjh asking me to do what I do not want to do.

I want to add the domain to cloudflare not my own dns or 3rd party.

Why am I getting this issue all of the sudden? And why never face this issue in the past?

This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.

No, it’s not. They’re not trying to add a he.net subdomain. That’s why your first post saying that was hidden.

1 Like

Right, but in order to do that you need to follow the proper process.

You need to add the domain in your Cloudflare account before you change the nameservers to Cloudflare’s. Currently you’re trying to do it in the wrong order which it why it’s not working.

Go back and start from scratch - reset the domain’s nameservers to the default ones at your registrar/host or he.net if they don’t offer it. Then add the domain to your account and then change the nameservers to the ones Cloudflare asks for.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.