Domain giving off 503 errors

Hi there,

I’m having some issues with my domain. I’m hosting 3rd party and have linked by DNSSEC and nameservers.

The DNS is all correct as the subdomain does work.
The domain giving the 503 error is pctoppers.nl, its subdomain (which is working fine) is dev.pctoppers.nl.

pctoppers.nl was pointing to a shopify site before this. I have redirected the DNS to point to the same server as the subdomain as that is the server the main site is hosted on too.

If you need any further information please let me know and I’ll provide it :slight_smile:

Thanks in advance!

By the way, I see this

1 Like

Yeah, that is the problem. If you check in console you’ll see a 503 error.
I kind of don’t know where to look at this point. I have paused Cloudflare on this site.

Do you want me to pause Cloudflare again to see what that does?

Try un-pausing it! This way, we can tell if Cloudflare is the issue or not!

It is currently unpaused

Are you sure?

Also, your site is insecure

image

Yes, please look the picture below:
image

The site appears secured for me.
image

Let me try and re-opening the website (in a different tab)

Ok, nope, it still doesn’t work!

Error starts happening when I enable universal ssl…

I’m now using a cert generated on another server but this doesn’t takeaway the fact that the problem still exists. The cert I have now doesn’t autorenew…

Also seems to happen when I turn on proxy…

Okay, I have established the problem.

When enabling Proxy in my Cloudflare DNS it will show me the 503 error. I’m also not receiving any requests from Cloudflare. This is not a Firewall issue as I have whitelisted all Cloudflare IP’s.

Steps to recreate this problem in my case:
I add

  if ($http_x_forwarded_proto != https) {
    return 301 https://$host$request_uri;
  }
  
  if ($http_x_forwarded_proto ~ https) {
    set $fastcgi_https on;
  }

in my vhost file.

I comment out:

  #if ($scheme != "https") {
  #  rewrite ^ https://$host$uri permanent;
  #}

It seems there is an issue on Cloudflare’s side… All my DNS is correct and I have the SSL on Full (not strict).

Is there anywhere I can report this to Cloudflare? I don’t think this is solvable with a thread…

I’m sorry to say this, but you have an insecure website!

Full (Strict) should be set in the SSL/TLS overview!

Here’s why:

Also, the insecure website could be a result of your SSL/TLS setting!

That is fun and all, but when I do that the site stops working. I don’t see data coming from Cloudflare when doing this or anything mentioned above.

This is something on Cloudflare’s end but there is simply no way to report something like this.

This problem still exists and I’m still unable to enable proxy on my domain because of an issue with Cloudflare. Is there some way I can contact Cloudflare directly about this issue?

Am I correct in understanding that the site works fine when Cloudflare is paused or :grey: and you only see this page when you proxy it?

If that’s the case then I think the quickest way to resolve this is with Shopify - please try contacting them and ask them to remove all Cloudflare configurations for your domain, specifically SSL for SaaS / Custom Hostnames. This error page appears to be Shopify’s and they likely did not clear out the configuration for your domain when you moved away from them so that is overriding your settings. If you still have access to their panel then you may be able to remove it yourself, but otherwise they should be able to manually remove it from their Cloudflare account.

1 Like

Hi there,

Yes, this is the correct understanding. We aren’t using shopify anymore and are hosting the website by ourselves now using CloudPanel and a VPS. I checked both with the hosting company and the CloudPanel developer and they are both pointing fingers to CloudPanel not sending data when I enable the Proxy.

Like you said, I have checked on our shopify panel and have unlinked our domain. I will check tomorrow if this has been solved. There is 1 strange thing however. The DNS of my domain has nothing pointing to Shopify anymore (since 72 hours).

I will wait a bit and try again tomorrow. I’ll keep you posted.

That should resolve it.

That won’t make a difference if Shopify still have the domain, because they use Cloudflare as well and hostname priority will put the SaaS provider in front of your setup.

1 Like

Okay that is clear. How long can it take before it is unlinked?

That depends on the SaaS provider (Shopify). Hopefully when you unlinked the domain in your panel, that should have triggered the removal of your domain from their Cloudflare configuration instantly and it should already be working.

Some providers queue up requests and process them all at a certain time and some have to do it manually via their support if their systems do not work as they should.

Sorry it’s a vague answer, I’d hope it would be pretty much instant but if it’s not then you may have to reach out to Shopify. I’d recommend contacting them if it’s more than 24 hours.

1 Like