Domain get redirected to incorrect location

Dear folks,

I bought a domain for my services, now today, instead of services working, it get redirected to https://annair.vercel.app/ website…

The whois shows that my domain point to cloudflare, and cloudflare panel says it redirect to correct server. but it actually goes into https://annair.vercel.app/ but I do not have such a service on my server, and even I blocked the port 80

What should I do?
What is happening?

Thank you

Pause Cloudflare and ensure your site loads fine on HTTPS without Cloudflare. Once that works, it will also work on Cloudflare.

Also make sure your encryption mode is Full Strict.

2 Likes

I couldn’t find encryption mode.
I paused cloudflare, … still getting redirected.
When I check the nslookup, I get clouflare address…

PS C:\Users\DELL> nslookup v4.deadmann.net
Server:  localhost
Address:  127.0.0.1

Non-authoritative answer:
Name:    v4.deadmann.net
Addresses:  188.114.96.3
          188.114.97.3

PS C:\Users\DELL> nslookup deadmann.net
Server:  localhost
Address:  127.0.0.1

Name:    deadmann.net

As you can see my main domain does not associate with IP,… when I use v4.deadmann.net which is only defined within the cloudflare DNS. it get forwarded to https://annair.vercel.app/

Then you need to set up the necessary DNS entries on Cloudflare. Your server probably does not recognise the “v4” hostname and redirects you.

The encryption mode is at https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls - make sure it is Full Strict

Yeah you are right, one of the services panels has a security measurement to redirect Users… then the reason my services is not working is something else.

Sorry to dept the service, but I also got a notice that made me worry today…

Dear customer and/or domain holder

We have received a request for the Authorization ID (‘AUTH-ID’) for
your domain

deadmann.net

That’s something to clarify with the registrar. But once the site loads fine on HTTPS, it will also work with Cloudflare.

1 Like

I just noticed that the redirect I mentioned is not this redirect… there is a file that redirect to some web page called zula, and that only shows a single logo. that is not this…

Not that v4 and v6 are only defined within cloudflare… and if I use the same IP using another domain such as g2.servers.ashiane.house:2053 it wont get redirected

Hi,
Same problem here, how can i fix this?
sad,

thank you

I am afraid you really need to fix this on the server, Cloudflare is not involved here. You need to talk to your host.

On Cloudflare you may just have to adjust the DNS entries.

Everyone, check Rules->Redirect Rules, someone added such redirection on all domains

2 Likes

The OP already clarified that it happens when unproxied as well.

There are a few reports on this URL at this point, however, so there is a chance that accounts were compromised. If so, check out Secure compromised account · Cloudflare Fundamentals docs and verify your Cloudflare configuration for any (redirect) settings which are not supposed to be there.

@mimosh_pisholack, also take a look at your audit log.

1 Like

I removed the v4. record from the cloudflare, performed dnsflush,…

the issue is if I use g2.servers.ashiane.house:2053 pointing to the exact same IP address… it works, but the other domain v4.deadmann.net goes to somewhere else …

  1. Verify that your account was not compromised and there are no configuration settings you didn’t set up
  2. Keep Cloudflare paused
  3. Contact your host to clarify which DNS entries you need and configure them
  4. Verify that your site loads fine on HTTPS when paused
  5. Once everything works, you can unpause
1 Like

yes it was pointing to the exact location…
I removed it, but it didn’t take effect

Did you follow the mentioned steps?

And are you sure you are configuring the right account?

it worked. I also enabled 2FA Authentication… are there any way to heck existing session, I do not wish to change password, just drop that one guy out is enough

You can log out active sessions on your profile screen.

1 Like