Domain for mobile not automatically forwarding to subdomain

I just setup Cloudfare yesterday and everything is working great. Instead of uploading my SSL certificate from Siteground - I went ahead and purchased one.

I created a subdomain to my site m.partyfavorz.com because I wanted a separate domain for mobile since they are not identical but everything is handled by my theme under the same domain.

Under the speed options --> Optimization --> Mobile Redirect, it states that it must be a CNAME for it to work and will be automatically redirected.

I changed the DNS A record for m.partyfvorz.com to a CNAME record that points to m.partyfavorz.com.cdn.cloudfare.net and then purged the cache for Cloudflare.

Yet, my mobile site is still showing up as partyfavorz.com without the subdomain “m.” I thought it would be instantaneous after the purge. Maybe I’m missing a step or need to wait longer. Can someone point me in the right direction?

That domain isn’t proxied by Cloudflare. It’s using SiteGround’s name servers, so you may have to enable Cloudflare over there.

I’ve used Mobile Redirect in the past, and it didn’t require a CNAME…though this may be different if you’re using a third party integration, such as SiteGround.

Please disregard my past two posts as I’ve deleted them. Anyway, I just want to thank you for pointing me in the right direction.

The issue was the SSL certificate and implementing it on Siteground’s SSL manager. It allows you to paste the certificate but generates its own key which it’s not supposed to do. The support agent saw the same thing.

Additionally, Let’s Encrypt was active on the site which overwrites the latter. They deleted it but still couldn’t install the newer certificate because of the above issue. It’s now been escalated to senior support.

Anyway, for those that purchase a certificate from Cloudfare, make sure to remove Let’s Encrypt or any other certificates on your host site before adding it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.