Domain down suddenly, with error 1101

we use cloudflare for our business linkr.bio, for months everything works just smooth and suddenly the whole site is down with error 1101, even we change the worker script to just response simple text, it still shows 1101.

Any suggestions what I can do?

Hi @service14,

It looks like you’ve turned off proxying on the domain?

It’s impossible to know what’s causing the errors without access to logs. You could take a look at the Logs tab of a Worker or try running wrangler tail -f pretty to see what errors are being thrown.

thanks for the reply @albert

the dev env still using cloudflare, people can access through https://dev.linkr.bio.

I have tried the tail command, but nothing come out, just seems that no one have access the site.

this drive me a little crazy.

1 Like

It can be a bit finicky to get working. Try doing the following:

  1. Open https://dev.linkr.bio/ in a browser.
  2. Run wrangler tail -f pretty in the Worker project folder.
  3. Wait 5 seconds after it successfully connects.
  4. “Hard-reload” the page using CTRL + SHIFT + R.
  5. Logs should start appearing in Wrangler Tail window.

@albert I have tried the Hard-reload way with no lucky, still got nothing on the Wrangler Tail window

the output of tail command is all there:

wrangler tail -f pretty --env dev

Connected! Streaming logs from linkr-dev … (ctrl-c to quit)

Hmm… are you sure the dev env is running on dev.linkr.bio? You could try running wrangler dev --env dev and navigating to http://127.0.0.1:8787/ - that should really work :slightly_smiling_face:

@albert It’s weird that if I run “wrangler dev”, the 8787 server works fine, but if I run “wrangler dev --env dev”, it gives strange output with
Error: expected value at line 1 column 1
and terminated.

What does the [env.dev] section in wrangler.toml look like?

@albert after I change “route” to “workers_dev = true”, the command “wrangler dev --env dev” works fine and i connected to http://127.0.0.1:8787, everything works fine. I even tried to publish it to https://linkr-dev.linkr.workers.dev, it works fine.

After I switch to route params and try https://dev.linkr.bio, same problem.

Error 1101 Ray ID: 69ae56866b535f91 • 2021-10-08 09:28:15 UTC

Worker threw exception

This really driver me crazy!

Could you ensure your version of Wrangler is up-to-date? If that doesn’t fix it we’ll need help from someone with more knowledge about the intricacies of Wrangler - I’m unable to debug it further without having the actual project in front of me.

@albert Thanks a lot, I understand.

I’ll try to update wangler and start pray!

In case somebody else see this thread, my problem is still there.

I raise a ticket to cloudflare, they just give me some random useless answer and close the ticket, a little disappointed to cloudflare.

Hi again!

Cloudflare Support is very limited on the free plan, especially when it comes to Workers and code debugging. If you join the Cloudflare Workers Community Discord we’ll be able to better help you :slightly_smiling_face:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.