Domain down after few times of settings changes

I bought the “somedomain.com” domain a couple of hours ago and set it up to access my homelab. Also made several subdomains for my services in my homelab. But, for some reason, the connection via the smb protocol did not work, although similar requests via http to the same address worked correctly. I changed subdomains and record format several times, trying to make a connection via smb, but after several attempts my domain simply stopped working. In the error pop-up there was something about a domain and a hijacking attempt, most likely due to frequent changes of the domain and its settings. Please 1) enable my “somedomain.com” domain 2) help me make a connection via smb to the same “somedomain.com” domain the same way it works via http

What is the real domain?

Note that the Cloudflare reverse proxy only works with HTTP/HTTPS (unless using Cloudflare Spectrum) so for SMB you will either need to have a separate subdomain set to “DNS only”, or use a Tunnel…

1 Like

unsteelix.cloud
it worked fine 1 hour and then after few setting changes for smb domain in tunnel page just fall down

Your domain is working ok.
https://cf.sjr.org.uk/tools/check?17e7f9661cfa4b6a8d674dfd90066447

If you are already using a tunnel, then use the documentation I linked to help you set it up.

1 Like

I’m already set up my tunnel and make all preparations. Main domain and few subdomains (Plex, and etc) was working excellent. But after few settings changing for smb subdomain my main domain stoped working - and now I’m see 404, but all subdomains still works correctly.
in the Public hostnames window there was something about hijacking, and I think that Cloudflare simply disabled my main domain due to frequent changes of domains/subdomains, etc.

i’ve tried make sub domain smb.unsteelix.cloud with tcp and localhost:445 for smb connection but nothing. But locally smb connection with the same parameters works perfectly

update: domain started works. I don’t know why. I didn’t change anything. Maybe just I have to wait few hours for updating…

p.s smb don’t work, but I’ll try to resolve it a bit later. sjr - very thanks. :handshake:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.