Domain displaying SSL and Cipher mismatch Error

ssl

#1

Hi guys,
from this morning m,y site showing ERR_SSL_VERSION_OR_CIPHER_MISMATCH error.

In details:

This site can’t provide a secure connection

www.mysite.com uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

HIDE DETAILS

Unsupported protocol

The client and server don’t support a common SSL protocol version or cipher suite.

Domain Summary
Security Level: High
SSL: Full (strict)
Caching Level: Standard
Development Mode: Disabled

After disabling the recommended A + CNAME records it’s all running fine, but I guess it shouldn’t be disabled.
Few days ago I got mail from cloudflare like something a,cname etc records systems are being changed (which is deleted currently, so I can’t recall properly).

So, can anyone help me with this?


#2

I’ve got the same error today…
My domain summary:
Security Level: Medium
SSL: Flexible
Caching Level: Standard
Development Mode: Disabled

It worked perfectly for months till today… Any solutions?

Greetings
Erik